Excel 2010 : INDEX et COMPARAISON ont un avantage

Icône_Excel10_33x32Doit être dans une feuille de calcul Excel mehrere Colonnes ensemble par rapport, et ciblé werte choisi c'est en contraste avec ça RECHERCHEV avec une combinaison de INDEX- Et Fonction COMPARER très confortable possible. Avec une RECHERCHEV, les colonnes doivent toujours être disposées d'une manière spécifique. La fonction INDEX peut utiliser tous tout Combinaisons de colonnes approcher.

 

Avec un petit Voir l'exemple censé être les deux fonctions INDEX et COMPARAISON une fois indépendant l'un de l'autre et une fois l'un dans l'autre imbriqué être décrit.

 

1. Fonction INDEX ()

un Cas d'utilisation pour la fonction INDEX est la suivante : On aimerait à partir de certain Matrice ou le complet Tabelle toujours un bestimmt est Valeur de la cellule a dépensé.

= INDEX (matrice, ligne, colonne)

Ainsi, la fonction INDEX recherche la cellule du quatrième ligne et troisième colonne comme ça:

= INDICE (A1 : D8 ; 4 ; 3)

2_INDEX

 

2. Fonction COMPARER ()

La fonction COMPARER recherche une valeur donnée dans une colonne puis affiche la ligne dans laquelle se trouve la valeur.

= COMPARER (critère de recherche ; matrice de recherche ; type de comparaison)

Pour un la correspondance exacte est donnée pour le type de comparaison un zéro une.

Donc si vous cherchez le rangéedans lequel la Valeur maximum la seconde colonne la fonction ressemble à ceci :

=VERGLEICH(MAX(B1:B8);B1:B8;0)

3_ COMPARAISON

 

3. Fonctions INDEX et MATCH imbriquées

Pour de vrai intéressant ce sera en fait quand vous aurez les deux Fonctions l'un dans l'autre imbriqué. Même dans ce cas, l'avantage pour certains cas par rapport à RECHERCHEV ne peut être vu que.

Pour ça Voir l'exemple est devenu un nouveau Tabelle sélectionné.

Il devrait maintenant être le numéro de membre certain Personne sont émis. Pour une RECHERCHEV, la colonne doit être à droite de la quatrième colonne. Ce n'est pas nécessaire ici.

=INDEX(A2:D8;VERGLEICH("Tim";D2:D8;0);2)

4_emboîté

 

___________________________________________________
Cette astuce vient de www.win-tipps-tweaks.de
© Copyright Michael Hille

avertissement:
L'utilisation incorrecte de l'Éditeur du Registre ou de ses astuces peut entraîner de graves problèmes de système pouvant vous obliger à réinstaller votre système d'exploitation. La falsification des fichiers du registre et l'utilisation des astuces sont à vos risques et périls.