HILFE!!! Kabelmodem-Netzwerk-DHCP

  • Hallo ... weiß jetzt langsam nicht mehr weiter!


    System: 2 PC's (WIN-2K + WIN-XP) jeweils mit Netzwerkkabel mit Switch verbunden, das Kabelmodem ist auch mit dem Switch verbunden. Über den ISP wird automatische eine IP-Adresse vergeben.


    Am Anfang hat alles (ziemlich lange) perfekt geklappt-beiden konnten gleichzeitig in's Internet.
    Dann konnte immer nur noch einer der PCs ins Netz - der andere musste sich dann über das Zurücksetzen der Netzverbindung die IP-Adresse vom anderen "klauen", damit dieser dann in's Netz konnte - d.h. aber für den anderen PC war die Verbindung dann nicht mehr möglich. Laut ISP ist das gleichzeitige Nutzen der Internetverbindung beider Rechner möglich. Ich hatte mich damit dann abgefunden und nutzte dann immer Wechsel die Internetverbindung.


    Doch nun geht der XP-Rechner überhaupt nicht mehr ins Netz. das Zurücksetzen der Verbindung klappt auch nicht mehr (wird mit einer Fehlermeldung abgebrochen) und er teilt ihm die 169.154.154.132 als IP-Adresse mit 255.255.0.0 als Subnet-Maske zu (ich glaube eine interne Adresse von Windows). Von dieser IP ist er nicht wegzubekommen. Außerdem wird in Taskleiste rechts die Netzwerkverbindung nicht mehr angezeigt (obwohl diese aktiv ist) - diese erscheint erst nach aufrufen der Netzwerkverbindungen.


    Ich weiß nicht mehr weiter ... vielleicht hat ja hier jemand eine Idee.


    Ric

  • Also ich seh das so:


    Beide PC müssen in der gleichen Arbeitsgruppe sein.
    Beide müssen eine unterschiedliche IP im gleichen Subnetz haben.
    (Das ist doch bei dir sich er gegeben oder?).


    Ich versteh nicht, wieso du schreibst, dass Windows eine eigene IP vergibt. Benutzt du einen DHCP Server? Wenn du fest vergeben sind, muss Windows da nichts mehr machen. (Die IP vom ISP und die Netzwerk-IP sind ja zwei unterschiedliche paar Schuhe).


    Wegen deiner Online-Problematik setze dich mal mit deinem ISP auseinander und lasse dir die DNS-Server-Adressen geben. In Netzwerken kann es schonmal mit der DNS Auflösung zu Problemen kommen.


    Freddie

    Damit erklären wir zu Recht das Gute zu dem, wonach alles strebt. (Aristoteles)

  • Ah, jetzt hab ichs auch gecheckt.
    Du nutzt wirklich einen DHCP-Server!
    Schalte den mal ab und trage feste IP ein...


    Freddie

    Damit erklären wir zu Recht das Gute zu dem, wonach alles strebt. (Aristoteles)

  • danke für die prompte antwort, ich glaub ich habe so langsam'n filmriss (sorry)


    den dhcp-server habe ich abgeschalten und neugestartet ... die IP-Adresse bleibt jetzt bei 0.0.0.0 nur kann ich keine festen IP-Adressen vergeben, da Windows sonst die IP-Adresse übers Kabelmodem (vom ISP) nicht bezieht, oder sehe ich das falsch.


    By the way: wenn ich bei Netzwerkverbidnung auf Reparieren gehen, erscheint eine Fehlermeldung: "Die folgenden Reperaturvorgänge sind fehlgeschlagen: die IP-Adresse wird erneuert, Alle DHCP-Leases werden erneuert und die DNS-Namen erneut registriert. Wenden Sie sich an Ihren ... usw."


    Fragen über Fragen. Ich verstehe auch nicht, dass das ganze am Anfang funktioniert hat und mit einem schlag nicht mehr ... es ist auch nichts an der Konfiguration verändert worden.


    Ric

  • Das mit der Reparatur ist klar, kann ja nicht, wenn du keine feste IP vergibst. (Ohne DHCP weiß dein XP ja nicht, was es da eintragen soll und trägt entweder 0.0.0.0 oder eben diese andere IP in deinem ersten Beitrag ein)


    Die IP im Netzwerk und die IP des ISP unterscheiden sich grundsätzlich und haben nichts miteinander zu tun.


    Gehe in der Systemsteuerung auf deine Netzwerkverbindung (lan) und dort unter Eigenschaften von TCP/IP gibt du den Rechner eine IP (z. B. 192.168.0.1 für Rechner 1 und 192.168.0.2 für Rechner 2, beide IP innerhalb des Subnetzes 255.255.255.0)
    Dann meldest du beide Rechner in der gleichen Arbeitsgruppe an: Systemsteuerung/System/Computername, dann Netzwerkkennung, da läßt du dir irgendeinen Namen einfallen, bei beiden Rechnern den gleichen.


    Du wirst weiterhin eine IP von deinem Provider erhalten. Die feste IP ist nur für die interne Netzwerkidentität!


    Wie ist das mit deinem Router, bzw. Switch? Am Wan-Port hängt dein Modem und an zwei Lan-Ports hängen die Rechner? Kannst du den Switch anpingen? Von beiden Rechnern?


    Viel Erfolg! Und halte mich auf dem Laufenden!



    Freddie

    Damit erklären wir zu Recht das Gute zu dem, wonach alles strebt. (Aristoteles)

  • hallo freddie


    dhcp-server ist abgeschalten. ich werde diesen jetzt auch am 2. pc abschalten (ich hoffe, das ich an diesem noch die internetverbidnung habe).
    ich habe dem xp-rechner nun die feste ip gegeben. gehe ich recht in der annahme, dass ich beim zweiten (WIN-2K-PC) auch erst die feste IP-adresse vergeben muss, damit dann beide wieder gleichzeitig online gehen können (der XP-PC noch tut's noch nicht)?


    sorry für die blöden fragen - das ist nur mittlerweile hilflosigkeit :roll:


    nebenbei beim ISP ein forum entdeckt, wo auch andere user das gleiche problem haben ... ich poste dir hier mal ein paar ausschnitte (vielleicht hilfts ja):


    Paracelsus : Beiträge geschrieben - 04/05/2004 : 20:16:58
    --------------------------------------------------------------------------------
    hallo, in unserem wg-netzwerk herrscht seit einigen wochen folgendes problem: das windowssystem (2 mal xp u einamal me) verliert permanent seine IP-adresse u schon is man nich mehr drin. Solange man alleine surft tritt das problem unregelmäßig auf. Sobald allerdings mehere Rechner versuchen online zu gehen, kommt es permanent zum ip-verlust.
    Da ist es dann auch nich wirklich hilfreich, wenn man dauernd im dos-modus "ipconfig /release" u "ipconfig /renew" eingibt. Dann funzt das netz zwar wieder, allerdings bei Mehrfachbenutzung meist nur 2-3min oder so.
    Kennt jemand das problem und/oder weiß eine Lösung bzw die Fehlerquelle??? Schonma Danke im voraus!


    matthias: Beiträge geschrieben - 04/06/2004 : 12:59:07
    --------------------------------------------------------------------------------
    hii, benuzt du einen Router ?
    Bei mit fällt auch sporadisch das Internet aus . Wenn ich genau darüber nachdenke, passiert das auch immer dann , wenn mehrere ins Netz connecten. Z.z. funzt es , aber manchmal fällt das internet lange aus


    Darky: Beiträge geschrieben - 04/07/2004 : 12:32:39
    --------------------------------------------------------------------------------
    ein switch kann leider nicht routen!! das problem liegt darin dass ihr ein netzwerk am modem habt dieses(netzwerk) aber kein bestandteil des muth-netzwerkes ist! somit müssen die netzwerke getrennt werden!
    anders gesagt über das modem wird eine IP dynamisch an einen endrechner vergeben welcher somit bestandteil des muth-netzwerkes wird! diese IP kann nur einmal vergeben werden und ihr könnt auch nur eine(IP) erhalten! und wenn ein pc(meist der 1. der eingeschalten wurde) die IP erhalten hat haben die anderen das nachsehen! ihr braucht einen router(hardware oder software) der die netze trennt! der router ist nichts anderes als n kleiner PC mit 2 netzwerkkarten ! die eine karte übernimmt die öffentliche IP adresse und die andere eine IP aus dem privaten netzwerk! der router weis dann wo welche adresse zu finden ist(ob im privatem netz oder im öffentlichen)und verbindet die pc's weiter
    ihr könnt in einen pc noch ne netzwerkkarte einbauen-diese separat mit dem modem verbinden und ihn(PC) als router nutzen-->dies hat den nachteil dass dieser pc zum surfen immer an sein muss!!! oder ihr kauft euch nen hardwarerouter!


    Paracelsus: Beiträge geschrieben - 04/07/2004 : 12:36:34
    --------------------------------------------------------------------------------
    und warum hat das dann ein halbes jahr lang problemlos funktioniert? Trotzdem danke schonmal!




    ... das also aus dem forum ... die haben das gleich problem (ich sollte mich eigenltich freuen, dass ich nicht der einzige bin, oder 8O nur 'ne lösung ist noch nicht in sicht) ...


    ric

  • Die Lösung ist nahe!


    1. Beide Rechner brauchen eine feste IP (siehe meinen Link)
    2. Diese IP muss im gleichen Subnetz sein.
    3. Die Arbeitsgruppe muss bei beiden PC die gleiche sein.


    Dein Switch hat auch eine IP (das ist die IP des so genannten Standard-Gateway, die sich natürlich von denen der beiden Rechner unterscheiden muss, aber ins gleiche Subnetz gehört).


    Versuche deinen Switch anzupingen (von beiden PC ausgehend)
    So machen: Start/Ausführen, dann eingeben: ping xxx.xxx.xxx.xxx (also die IP des Switch, testweise auch die des anderen Rechners.
    Wenn da was passiert, Glückwunsch (da steht dann sowas wie Antwort von xxx.xxx.xxx.xxx ...Datenbytes erhalten...etc.)


    Hast du die ersten drei Schritte befolgt und erfolgreich abgeschlossen (positiver ping-Befehl), machst du dich an die http://www.-Verbindung.


    Dazu bräuchte ich aber mehr Info über deinen Switch. Ist das nun ein konfigurierbarer Router?


    Alternative für gemeinsame Nutzung der http://www.-Verbindung: Rechtsklich auf die Netzwerkverbindung/erweitert und dort dann die gemeinsame Nutzung aktivieren (musst dich da mal umgucken, habe das selbst nicht so, sondern über einen Router...)


    Freddie


    PS: Du stellst keine blöden Fragen

    Damit erklären wir zu Recht das Gute zu dem, wonach alles strebt. (Aristoteles)

  • sooo ... also das mit den festen IPs geht ja, hatte ich schon früher so gehabt. musste bloß jetzt erstmal den urzustand wieder herstellen, da die inet-verbindung weg war ... ich hatte auch fälschlicherweise, den DHCP-Client gestoppt :oops: der DHCP-Server ist (glaube ich) gar nicht aktiv.


    so, nun zum switch, das ding ist ein SITCOM LN-112, schimpft sich Aktiv-Switch und ist (denke ich zumindest) nicht konfigurierbar. jetzt die große frage, wie kriege ich die IP-Adresse (und auch die SUBnet) raus. auf der rückseite ist keine gekennzeichnet.


    ric

  • Das Subnetz kannst du mit 255.255.255.0 angeben, das klappt.
    (Das wird doch sogar automatisch so eingestelltm, wenn du eine IP aus dem privaten Bereich, also eine mit 192.168.xxx.xxx angibst, denke ich)


    Die IP müßte im Handbuch stehen. Standardmäßig ist das meistens 192.168.0.1, wobei dann für deine Rechner statt der 1 die 2 und die 3 übrigwären. (Wenn du die anpingst, mekrst du das ja).


    Dann sollte alles klappen!


    Schau auch mal in der Sektion Weblinks hier im Forum unter Online/Netzwerk. Da ist auch ne Menge zu finden.


    EDIT: Wenn du die IP vom Switch hast, kannste die ja mal spasseshalber in der Adressleiste deines Browsers eingeben, wenn das Switch ein Web-Interface hat, kommst du so ins Konfigurationsprogramm...


    Freddie

    Damit erklären wir zu Recht das Gute zu dem, wonach alles strebt. (Aristoteles)

  • sorry, herstellername war falsch: sitecom ist korrekt.


    habe gerade mal versucht das switch anzupingen (verschiedenes IPs probiert) ... keine reaktion.
    meiner meinung nach funktioniert das switch eher wie ein aktives hub ... da die IP-adresse vom ISP zum WIN-2K-Rechner durchgereicht wird ... damit hat der WIN-2K-PC eine zum ISP-Netzwerk gehörende IP-Adresse.


    muß hier evtl. doch ein router her?


    ric

  • Wie gesagt, die IP die vom Provider kommt hat nichts mit der Netzwerk-IP zu tun. Trotz fester Netzwerk-IP, kommt trotzdem eine Provider-IP durch. Bei mir ist das so und ich habe einen Router.


    Wenn du ohnehin über einen Router nachdenkst, dann würde ich das unterstützen, ist nämlich sehr komfortabel, sehr leicht und umfangreich konfigurierbar.


    Was klappt denn jetzt noch nicht bei dir?
    (Ich muss nämlich jetzt mal die Heier machen... :oops: )


    Freddie

    Damit erklären wir zu Recht das Gute zu dem, wonach alles strebt. (Aristoteles)

  • ich würde auch sagen, wir machen hier erstmal'n break ...


    ich teste alles nochmal in ruhe durch ... bist du oft hier, damit ich dich auf dem laufenden halten kann?


    ric

  • Fast jeden Tag. So wie VIELE andere. 8)


    Das Forum ist mächtig! Doppel 8)


    Gruß,


    Freddie

    Damit erklären wir zu Recht das Gute zu dem, wonach alles strebt. (Aristoteles)

  • okeedokee ...


    kurze frage noch: kannst du mir einen router empfehlen? es sollen maximal 2 rechner und das kabelmodem per RJ45 angeschlossen werden? habe gerade mal nachgeschaut, sehe fast ausschließlich irgendwelche DSL-Router und wie siehts mit der geschwindigkeit aus (10/100 oder nur 10 MBit/s)?


    ric