Gparted, nach Partitionierung BS weg

  • Hallo Paulemann, hallo Community!

    Ich bin seit gestern stolzer Besitzer eines Vista-PCs und wollte ihn natürlich erstmal partitonieren, bevor ich ihn benutze.

    Dank Paulemanns Artikel hab ich mein Glück mit GParted versucht, aber dabei evtl. einen Fehler gemacht - bei mir hat das leider nicht wie auf der Homepage von GParted beschrieben funktioniert. Vielleicht könnt ihr mir weiterhelfen, da ihr versierte GParted-Benutzer zu sein scheint.

    Ich hab die aktuelle Version 0.3.4-10 heruntergeladen (das war bei mir nur eine .iso-Datei), und diese auf CD gebrannt (und den Haken bei "bootfähig" gesetzt. Dann im Bios Bootreihenfolge geändert und CD eingelegt.

    Nach dem Neustart ist auch was passiert, allerdings kam nicht die grafische Oberfläche von GParted, sondern erst ein kurzer Hinweis auf mein Disketten-Laufwerk (etwa in der Form von "1. 1,44 Floppy irgendwas" - das war leider sehr schnell weg) und danach "Preparing to start your computer" "Mouse driver installed succesfully" "A:\>"

    Wobei er aus meinem DVD-Laufwerk A gemacht hat.

    Wisst ihr, was ich falsch gemacht habe? Als ichs ein zweites Mal mit einer neuen CD probiert habe, ohne den Haken bei bootfähig zu machen, ist gar nichts passiert; und als ichs mit der ursprünglichen Version mehrmals versucht habe, kam immer wieder der gleiche Vorgang.

    Müssen auf die Cd noch andere Dateien?

    Vielen Dank schon im Voraus für Eure Hilfe.

    Viele Grüße,

    Chrisi

  • Hi Chris,


    Du mußt nicht das ISO als Datei auf eine Daten-CD brennen, auch nicht auf eine bootfähige Daten-CD, sondern über die Funktion "CD aus ISO-Abbild brennen" Deines Brennprogrammes den Inhalt des Abbildes 1:1 auf die Scheibe bringen. Die CD muß finalisiert werden, damit sie auch in einem anderen Laufwerk als dem Brenner startet. Meist ist der DAO-Brennmodus (Disk at once) eine gute Wahl.


    Grüße
    Funkenzupfer.

    \"Wo kämen wir hin, wenn alle sagten, wo kämen wir hin, und niemand ginge, um einmal zu schauen, wohin man käme, wenn man ginge.\" (Kurt Marti)

  • Hallo Funkenzupfer,

    vielen Dank für die schnelle und hilfreiche Antwort!

    Das hab ich dann ja mal komplett missverstanden ;)

    Ich werds heute abend, wenn ich zu Hause bin, gleich nochmal probieren, so wie du's beschrieben hast und mich dann nochmal melden.

    Meinst du mit finalisieren, dass ich die CD nicht als Multisession starten darf?

    Vielen Dank nochmals!! :sehrgut:

  • Hallo Chris,


    Genau das. "CD abschließen, so daß keine weiteren Daten mehr darauf geschrieben werden können."


    Grüße
    Funkenzupfer.


    P.S.: Das Verhalten Deiner gebrannten bootbaren Daten-CD (die mit dem ISO-Image als Datei), als "Floppy-Laufwerk" zu starten, ist übrigens völlig korrekt, denn was dabei passiert ist nichts anderes, als das ein Image einer Startdiskette von DOS (oder eines anderen Betriebssystems) mit auf die CD gebrannt wurde, von dem aus dann gebootet wird. Um auf die Daten auf dem Rest der CD zugreifen zu können, muß dieses kleine Image die entsptrechenden CD-ROM -Treiber enthalten und laden. (was normalerweise auch der Fall ist). Du könntest Dir also theoretisch per DIR-Befehl die ISO-Datei, die unausgepackt auf der CD liegt von außen ansehen, wenn Du an der Eingabeauffordeung A:\> die entsprechenden Befehle eingibst. An das darin befindliche Programm kommst Du unter DOS/WINDOWS so aber trotzdem nicht, sowas ginge nur mit Unix/Linux-Systemen, die entsprechende Werkzeuge (wie z.B. mount) an Bord haben um z.B. schon den Systemstart direkt aus einem solchen Image heraus zu bewerkstelligen.

    \"Wo kämen wir hin, wenn alle sagten, wo kämen wir hin, und niemand ginge, um einmal zu schauen, wohin man käme, wenn man ginge.\" (Kurt Marti)

  • Sooo, jetzt konnt ichs alles zu Hause probieren - und siehe da, es funktioniert glaub ich!

    Vielen Dank nochmal Funkenzupfer für die ausführliche Beschreibung. :sehrgut: Ich hab die CD genau so gebrannt, wie du's gesagt hast (der NTI-CD-Maker hatte sogar die gleichen Begriffe wie du verwendet) und wenn ich jetzt boote, lädt das Programm richtig.

    Ich hab vorher auch mal versucht, mit dem DOS-Befehl DIR zu schauen, was auf der CD ist, und hab auch mal ne .exe gestartet, weil ich hoffte, dass das klappt, aber dann war mir das doch zu unsicher und ich hab abgebrochen.

    Auf jeden Fall sieht jetzt alles sehr gut aus. Ich schätze mal, der PC wird die nächsten Stunden zu knabbern haben, zumindest hat er für den ersten von 5 Schritten schon ne halbe Stunde gebraucht.

    Letzte Frage: In der Beschreibung von GParted auf der offiziellen Homepage machen die Jungs die wildesten Partitionen mit den unterschiedlichsten Formatierungen. Ich hab immer "Primärpartition" (zur Auswahl standen noch "logische" und "Erweiterungspartition") und "NTFS" gewählt. Am Ende müsste dann die Bootpartition C und drei Primäre Partitionen (für Programme, Daten, Spiele) mit NTFS herauskommen. Ist das richtig, oder hätt ich da was anders machen müssen?

    Danke schon mal im Voraus. :)

  • Scheiße!

    Der ist doch schneller fertig geworden als gedacht und nachdem ich GParted beendet und die CD ausgeworfen und den Bootmanager geändert hab, kommt folgende Meldung:

    Windows Start-Manager:

    Fehler beim Starten von Windows

    Datei: \Windows\system32\winload.exe konnte nicht geladen werden, da die Anwendung fehlt oder beschädigt ist.

    Was hab ich falsch gemacht? :confused:

    Hilfe, ich wollt doch nur Partitionieren...unter XP und mit Partition-Magic hat das immer alles funktioniert :-(

    Weiß zufällig jemand Rat?

  • Ich habe das ganze jetzt mal in ein neues Thema verschoben, ich glaube das wird was länger.


    Also fange ich mal wieder mit ein paar Fragen an:


    Auf der Festplatte war ein BS (Vista) installiert?


    Hast Du dann mit Gparted die Partitionen gelöscht und neu erstellt, oder die bereits vorhandenen nur in der Grösse geändert?


    Wenn Du die Partitionen gelöscht und neu erstellt hast, dann hast Du C: (zumindest die alte C Part.) wirklich platt gemacht und musst wahrscheinlich das BS neu installieren.

    Wer nicht weiss wovon er redet sollte besser die Klappe halten.
    Also: Schnauze Welt!

  • Hallo Mike, Danke fürs Verschieben.

    Der Rechner hat eine 500 GB-Platte, die eingangs nur aus einer Partition bestand und auf der Vista Ultimate 32Bit installiert war (ist?). Mein Ziel ist es, 4 draus zu machen.

    Dazu hab ich mit GParted erstmal die Größe der Partition auf 50 GB geändert. Danach mit "new" eine zweite Partition mit 40GB erstellt, und im Pop-Up Menü "Primäre Partition" (zur Auswahl stand nur noch "Erweiterungspartition") und "NTFS" (hier gabs massig Möglichkeiten, aber die Platte ist NTFS formatiert, drum hab ich das genommen) ausgewählt.

    Den Schritt hab ich dann noch 2x ausgeführt, bis ich meine 500GB zugeordnet hatte, und dann auf "apply" geklickt.

    Dann hats ne knappe Stunde gedauert, bis es hieß, alle Vorgänge seien ausgeführt. Gparted hat die CD ausgeworfen, ich den Rechner neu gestartet, im Bios die Bootreihenfolge geändert und dann kam die Fehlermeldung.

    Jetzt stell ich mir die Frage, ob ich irgendwas verschusselt hab (hab ich sicherlich) und ob das per GParted zu retten ist, oder ob das System neu drauf muss.

    Achja, ich bin eben nochmal mit GParted rein, und die erste (linke Partition) hat noch immer ihre knapp 14 GB an Daten drauf.

    Aber ich bin völlig planlos :confused:

    Herzlichen Dank schon mal im Vorfeld für jedwede Hilfe!

    Beste Grüße,

    Christian

  • Also, da die Daten noch angezeigt werden, und du ganz richtig die vorhandene Partition nicht verkleinert hast, kann es erstmal gar nicht so schlimm sein (denke ich).


    Ich denke als einfachste Variante mal die Vista Installations-DVD einlegen und statt "jetzt installieren" auf "Computerreparaturoptionen" klicken, vll. reicht es ja wenn Vista eine Reparatur der Installation vornimmt.


    Dabei sollten die installierten Programme und Dateien ja erhalten bleiben.

    Wer nicht weiss wovon er redet sollte besser die Klappe halten.
    Also: Schnauze Welt!

  • Oki, DAnke, werd ich gleich mal testen.

    Ich hoffe, das klappt auch mit der "OEM-Wiederherstellungs-DVD" von Vista Ultimate, die meinem vorkonfigurierten Rechner beigelegen hat. Hoffentlich kann die das gleiche, wie ne "echte" Vista-DVD.

    Ich probiers gleich mal, Danke für den Tipp.

  • Herzlichen Dank nochmal Magic Mike und Funkenzupfer für eure Hilfe bei meinem Problem - ohne euch hätte ich das nie gebacken bekommen.

    Ich hab jetzt mit der OEM-Vista-DVD ne Reparatur gemacht, danach hat er ganz normal gebootet und im Vista die 3 neuen Partitionen (die ich heute nachmittag angelegt hatte) erkannt und einen Neustart verlangt.

    Danach lief alles reibungslos. Vielen Herzlichen Dank! :sehrgut:

    Da Vista für mich komplett neu ist, hab ich noch eine Frage: Ist es normal, dass ich Dateien nur mit Admin-Kennwort DIREKT auf eine Partition kopieren/von dort löschen kann? Das wollte er nämlich bei meinen Tests, ob die Partitionen auch funktionieren gerade eben. Wenn ich aber in den Partitionen einen Ordner erstellt habe (ohne nach dem PW gefragt zu werden) konnte ich in diesen problemlos kopieren.

    Ist das normal bei Vista? Danke und viele liebe Grüße, Christian