Festplatte läuft ständig und ohne Grund

  • Mist!


    Ich habs seit ca. zwei Tagen auch!
    Notebook: Dell 510m
    Festplatte: Toshiba irgendwasGAX
    XP Pro SP2 mit allen Updates


    Das Notebook hab ich seit zwei Monaten und das Problem ist in der letzten Tagen vereinzelt aufgetreten und seit ca. zwei Tagen dauerhaft. Alle 1-2 Sec ein ganz kurzer Zugriff auf die Platte. Es nervt einfach nur!


    Ich stehe zwar kurz davor auf eine andere Platte umzusteigen (die 5400er ist mir zu laut), würde aber trotzdem die Ursachen gerne wissen...

  • Zitat von Lordhelmchen

    das xp an der registry rumwurschtelt hab ich ja gefressen mittlerweile. aber jetzt mal im ernst starfighter: welchen grund sollte xp haben an der registry rumzutüfteln wenn ich grad nix an der kiste mache?


    Es werden STÄNDIG Statistik Informationen in die Registery geschrieben wie z.B. CPU Auslastung, freies RAM, freie Virtuelles RAM usw. usw.
    Halt alles, was man im PerfMon (Leistungsdaten) sich anzeigen lassen kann und das ist nicht gerade wenig.


    Und ja, meine Festplatte wird auch in regelmäßigen abständen genutzt, ohne das ich was mache, nur macht meine dabei keinen Lärm.


    Zitat

    Du kannst mir erzählen was du willst, und vielleicht auch gähnen bis dir die dritten rauspurzel, aber das was ich habe, ist ein problem.


    Richtig, aber meiner Meinung nach ein Festplattenproblem. Weil, wenn die keinen Lärm machen würde, wüstest Du wahrscheinlich nicht mal was von den ständigen zugriffen.


    Zitat

    Wenn deine platte powersaved, hast du eben dieses problem nicht.freu dich :-)


    Nein, DU verkennst es immer noch.
    JEDE Festplatte hat einen eingebauten Cache, der unterschiedlich groß ist. Im Schnitt heutzutage zwischen 2 und 8 MB.
    Angenommen die Platte geht nun in den Powersave zustand, dann wäre es natürlich reichlich blöd, wenn jeder Zugriff diese direkt wieder aufwecken würde.
    So schreibt die Festplattenelektronik die Daten eben in den Cache und läst die Platten selber stehen.
    Weil, Powersave heist ja nicht, das die Plattenelektronik nicht doch arbeitet. Nur der Motor steht eben.
    Müßen nun Daten gelesen werden, die schon im Cache sind, bleibt die Platte auch weiterhin aus. Erst wenn Daten gelesen werden sollen, die nicht im Cache sind oder der Cache voll wird, dann wird die Platte wieder gestartet.


    So, und wenn bei Dir aus irgendwelchen Gründen exakt dieser Cache nicht läuft, sei es, weil er kaputt ist oder die Platte nie einen hatte, dann kann es eben zu den von Dir beschriebenen effekten kommen.


    Zitat

    der cache is übrigens EINGESCHALTET (siehe viel weiter oben). ich bin zwar ein bissel unbedarft, aber net dusselig.


    Welcher Cache ?
    Der Plattencache oder der Windows Cache für die Platten ?
    Sorry, aber das ist definitiv ein Unterschied.
    Woher weist Du also, das der Plattencache eingeschaltet und Funktionsfähig ist ?


    Zitat

    An Peter: Neuinstallation hab ich schon 2x probiert. Kein Erfolg.


    Und somit ein Beweis, das es nicht an Windows oder irgendwelchen Tools liegt, sondern doch ein Hardware defekt ist oder der Cache per Software deaktiviert wurde.

  • kenne deinen feind


    vielen dank peter, dass du drauf gedrängt hast filemon nochmal anzuschmeissen. hab ich gemacht und erstmals advanced output gesetzt (ist leider im default auf aus) und jetzt taucht folgendes auf:


    17:04:16 System:4 IRP_MJ_SET_INFORMATION F:\WINDOWS\system32\config\default.LOG
    17:04:16 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:16 System:4 IRP_MJ_WRITE F:\WINDOWS\system32\config\default.LOG
    17:04:16 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:16 System:4 IRP_MJ_FLUSH_BUFFERS F:\WINDOWS\system32\config\default.LOG
    17:04:16 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:16 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:16 System:4 IRP_MJ_WRITE F:\WINDOWS\system32\config\default.LOG
    17:04:16 System:4 IRP_MJ_WRITE F:\WINDOWS\system32\config\default.LOG
    17:04:16 System:4 IRP_MJ_WRITE F:\WINDOWS\system32\config\default.LOG
    17:04:16 System:4 IRP_MJ_FLUSH_BUFFERS F:\WINDOWS\system32\config\default.LOG
    17:04:16 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:16 System:4 IRP_MJ_WRITE F:\WINDOWS\system32\config\default.LOG
    17:04:16 System:4 IRP_MJ_FLUSH_BUFFERS F:\WINDOWS\system32\config\default.LOG
    17:04:16 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:16 System:4 IRP_MJ_WRITE* F:\WINDOWS\system32\config\default
    17:04:16 System:4 IRP_MJ_WRITE* F:\WINDOWS\system32\config\default
    17:04:16 System:4 IRP_MJ_WRITE* F:\WINDOWS\system32\config\default
    17:04:16 System:4 IRP_MJ_WRITE* F:\WINDOWS\system32\config\default
    17:04:16 System:4 IRP_MJ_SET_INFORMATION F:\WINDOWS\system32\config\default.LOG
    17:04:21 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:21 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:21 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:26 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:26 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:26 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:27 System:4 IRP_MJ_WRITE* F:\$Mft
    17:04:27 System:4 IRP_MJ_WRITE* F:\$Directory
    17:04:31 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:31 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:31 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:51 System:4 IRP_MJ_CLOSE F:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Microsoft\Network\Connections\Pbk\rasphone.pbk


    das wiederholt sich alle 40 sec:


    17:04:56 System:4 IRP_MJ_SET_INFORMATION F:\WINDOWS\system32\config\default.LOG
    17:04:56 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:56 System:4 IRP_MJ_WRITE F:\WINDOWS\system32\config\default.LOG
    17:04:56 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:56 System:4 IRP_MJ_FLUSH_BUFFERS F:\WINDOWS\system32\config\default.LOG
    17:04:56 System:4 IRP_MJ_WRITE* F:\$LogFile
    17:04:56 System:4 IRP_MJ_WRITE* F:\$LogFile
    ...


    damit handelt es sich tatsächlich um die registry: HKEY_USERS\DEFAULT
    und ich entschuldige mich höflichst und sehr gerne bei starfight, der das schon längst vermutet hat!


    auffällig bei dem protokoll ist, dass nur dieser systemprozess IRP_MJ_FLUSH_BUFFERS aufruft (vsmon, explorer ... nicht). vielleicht macht das den lärm?


    damit habe ich wohl schlechte karten die ständigen geräusche loszuwerden, oder könnten noch controllereinstellungen, bios ... was bringen?


    ps: es ist wirklich terror - ich mache seit 2 wochen fast nichts anderes

  • Hallo.


    Trotzdem stimmt da was nicht.


    Kannst du die Log-Datei nicht "$LogFile" sondern diese "F:\WINDOWS\system32\config\default.LOG" öffnen und den Inhalt wenn er nicht so groß ist hier posten?


    Gruß Peter

    Birsctihe Frshocer hbaen haruesgfnuedn, dass es eagl ist, in whlecer Rhieenfgloe die Behsucbatn eenis Wtores sheten, slognae der etsre und ltetze Bhsucbate am rhitirgcn Pltaz sehten.

  • Entschuldigung angenommen. :-)
    Ich schmeiss grad meinen Notebook an und schau dann mal mit Filemon, was der so macht.
    Au weh. Das sind aber viele Programme, die da bei mri ständig auf die Festplatte zugreifen.
    OODefrag, MS-Messanger, Windows Update Manager, Bluetooth und und und.
    Naja, mal nach und nach eleminieren. ;.)


    So, bis auf ein paar Systemprozesse habe ich es so weit, das ausser Windows keiner mehr auf die Platte zugreift.
    Das sind aber immer noch ettliche Teile, die das machen.
    csrss.exe
    Servic~1.exe
    explorer.exelsass.exe
    svhost.exe
    winlogon.exe


    Und all diese greifen mit schöner regelmäßigkeit auf die Platte zu.
    Nun, ich muß zugeben, meine Platte ist so leise, ich höre die gar nicht. Ich muß jetzt wirklich mal das Ohr ans Notebook legen, um zu hören, ob die in Powersafe geht oder nicht.
    So, Energieverwaltung, kleinster Wert ist 3 Minuten. So lange muß ich dann nun mal warten. :-)
    Ach ja. Ich hatte "Advanced Output" NICHT aktiviert.


    Tja, nach ca. 3 Minuten geht meine Festplatte tatsächlich aus.
    Leider hatte ich den Filemon im Hintergrund, sodas ich nicht sehen konnte, ob da noch zugriffe stattfinden oder nicht.
    Ich lass den jetzt mal offen und warte nochmal 3 Minuten. Mal sehen, ob die dann auch noch aus geht.


    Tja, leider nicht. Solange der Filemon läuft, nix mit Festplatte abschalten.
    Was man aber sehen kann, obwohl bei mir ettliche Programme auf die Festplatte zugreifen, schaltet diese in Powersafe.


    Ich vermute bei Dir immer noch einen defekt der Festplatte oder des Cache.
    1. Weil die so einen Lärm macht, was meine nicht macht.
    2. Weil die nicht abschaltet, meine aber schon, obwohl Programme darauf zugreifen.
    Vieleicht hast Du mal ein Tool benutzt, mit dem man solche EInstellungen in Windows oder sogar an der Festplatte selber durchführen kann. Ach ne, Windows hattest Du ja schon mal neu Installiert, wenn ich mich recht entsinne.
    Aber es gibt Tools für die Festplatte, in aller Regel vom Hersteller, mit denen man da auch an den Einstellungen rumspielen kann.


    Tja, ansonsten fällt mir dazu nur ein, dir dann mal ne neue Festplatte zuzulegen. Du wolltest doch sicher eh schon immer mal ein paar GB mehr haben, oder ? :-)


    Ach ja. Eins noch. Der Notebook war von Dell ?
    DIe sind in solchen Dingen etwas komisch. Oftmals haben die ein ganz eigenes BIOS. Vieleicht kann man da ja was einstellen.


  • ServiceLayer.exe ist ein Bestandteil von der PC Suite.;-)

  • vielen dank für euren unermüdlichen einsatz!


    @supergiggi
    systemwiederherstellung bringt nichts


    Peter
    an die default.log kann man normal nicht ran, hab aber mein 2. os (xp home auf c: ) gestartet und dann die datei kopiert:
    ----------------------------------------
    regfT T £»¦a
    Å t e m R o o t \ S y s t e m 3 2 \ C o n f i g \ D E F A U L T {3050F3B2-98B5-11CF-BB82-00AA00BDCE0B} èÿÿÿvk Z °? ÿÿÿM i c r o s o f t H T M L J a v a s c r i p t P l u g g a b l e P r o t o c o l ÿÿÿnk ªØ"»YÅ ? ÿÿÿÿÿÿÿÿ ’ PJ ÿÿÿÿ B InProcServer32 èÿÿÿvk B ˆ‘ ¸ÿÿÿ% S y s t e m R o o t % \ S y s t e m 3 2 \ m s h t m l . d l l Øÿÿÿvk ø‘ ThreadingModel èÿÿÿoÛ­DIRTÿ ÿ ÿ ÿÿ ÿ ÿ ÿ ÿÿÿÿ ÿ ÿ ÿ
    ----------------------------------------


    ein paar interessante hinweise enthält das ja, werd ich mal nachforschen und dann wollt`ich noch nachsehen was
    F:\$LogFile, F:\$Mft und F:\$Directory bedeutet (aus filemon ausschnitt)


    @starfight
    ein nettes hörspiel, habs sehr plastisch vor mir gesehen. und damit wird mir immer klarer, dass an der hd oder den einstellungen was nicht stimmt. komischerweise waren die benchmarktests von s.a.n.d.r.a sehr gut?!


    to be continued...

  • Hallo,
    aller seit, ich habe folgendes gemacht und, dann hat es aufgehört zu Rattern :


    Erstmal Defragmentierung c: gemacht, unmittelbar danach hat es aufgehört, nach neuem start wieder das rattern, da nach Fehlerüberprüfung C: – neu Start Prüfung ging nicht vorwärts. Dann Restart Ins Bios rein und habe Default eingestellt. Neu start ging die Fehlerüberprüfung reibungslos weiter . Und jetzt rattert es nicht mehr.

  • Zitat von Anonymous

    Wollte nur mal anmerken, dass es kein XP Systemprozess ist...


    Hatte auch niemand gesagt, das es ein Systemprozess ist.
    Ich schrieb ja, das ich bis auf ein paar Systemprozesse es soweit habe, das niemand mehr auf die Festplatte zugreift.
    Das sagt nicht aus, das ich nur noch Systemprozesse laufen habe, sondern das niemand mehr auf die Platte zugreift, außer ein paar Systemprozesse.



    Aber super, das es jetzt wieder geht.
    Ich hatte zwar am 07.02 schon mal gesagt, Du solltest mal einen Blick ins BIOS werfen, aber naja. :-)
    Wer hat den da bloss an den Einstellungen rumgespielt. Na ?

  • Hi,
    hast Du unter den Laufwerkseigentschaften den Haken bei "Laufwerk für schnelle Dateisuche indizieren" drinnen?! Das ist auch ein Grund für das Arbeiten einer Festplatte im Ruhezustand!

  • Hallo,


    ich habe dieses Forum mit Interesse gelesen, wiel mein Medionbook, ja das riesige und häßliche neue teil vom aldi) nach einem Totalabsturz auch rumspinnt und unter anderem die beschriebenen ziemlich leisen, aber ständigen kurzen und irre nervigen Fstplattenzugriffe verursacht. Habe autoindex ausgeschaltet, die auslagerungsdateien auf feste größe gestellt, Outlook registries geändert., defragmentiert.. etc... nichts hat bei mir bis jetzt gewirkt. Vielleicht ist es ja auch echt ein plattenfehler...? Jedenfalls klappt das APM auch nicht. wenn ich die platte mit dem tool disksleep manuell in den ruhezustand zwinge, startet sie im systemleerlauf! nach einigen sekunden automatisch wieder und alles geht von forne los. im bios kann ich die platte leider nicht konfigurieren, da keine einstellungen vorhanden sind (außer irgendetwas mir 32bit einstellung?). könnten es eventuell auch korrupte dateien sein, so dass der lesekopf sich nicht richtig positionieren kann und das ständig wieder versucht???


    Wäre nett wenn ein leidgeplagter, der die ursache jetzt raus hat die löung nochmal für alle ebenfalls darunter leidenden in einfachen schritten schildern und posten könnte...


    Vielen Dank,


    Julius