AutoPlay öffnet Ordneransicht und nicht Aktionsauswahl

  • Hallo,


    meine Fragen befinden sich am Ende des Textes.
    Vorher folgt eine ausführliche Info.



    Wir haben mehrere Acer-Notebooks TM 292 LMi mit Win XP Pro SP1 und SP2.
    (Das SP hat aber keine Auswirkungen auf das Problem.)


    Wenn man nun daran einen USB-Stick oder eine Digitalkamera per USB anschliesst, öffnet sich bei einigen Notebooks die Ordneransicht, bei den anderen erscheint die "Eingabeaufforderung, um Aktion auszuwählen".
    Dort kann man dann u.a. den Scanner- und Kamera-Assistenten auswählen.
    Autoplay funktioniert also, nur erscheint auf manchen Maschinen nicht die "Eingabeaufforderung, um Aktion auszuwählen".
    Vorher ging aber bei _allen_ NB's Eingabeaufforderung auf. Nur
    irgendwann hat sich das von selbst verstellt. Und nicht nur auf einer Maschine.


    Im CD-Laufwerk hingegen funktioniert die "Eingabeaufforderung, um Aktion auszuwählen", nur anscheinend per USB nicht.



    Folgendes habe ich bisher gemacht:


    In den Eigenschaften der Wechseldatenträger ist auf dem Reiter
    "Autoplay" bei
    "Musikdateien", "Bilder", "Videodateien" und "Gemischter Inhalt"
    _immer_
    "Eingabeaufforderung, um Aktion auszuwählen"
    markiert.
    Auch wenn man unter "Bilder" bei der durchzuführenden Aktion den Scanner- und Kamera-Assistenten direkt auswählt, öffnet sich immer der Explorer, wenn die Kamera angeschlossen wird.


    Ich habe auch schon gegoogelt aber nichts gefunden, was das Problem beheben könnte.
    Mir ist nur aufgefallen, dass viele dieses Problem haben und es
    anscheinend keine Lösung dazu gibt. Kann das wirklich so sein?


    Das Tool "Fix Autoplay" von Microsoft habe ich auch benutzt. Aber es findet keinen Fehler (wie auch, Autoplay selbst funzt ja).


    Mit TweakUI aus den XP-Powertoys kann ich Autoplay aus- und
    einschalten. Darauf reagiert auch der Wechseldatenträger.



    Nun meine Fragen:


    Wie kann ich erreichen, dass auf allen NB’s bei Anschluss einen
    Wechseldatenträgers per USB, wieder die "Eingabeaufforderung,
    um Aktion auszuwählen" erscheint?


    Wie lautet der Befehl, mit dem nach anschliessen eines
    Wechseldatenträgers die Ordneransicht automatisch aufgerufen wird?


    Wie lautet der Befehl, mit dem nach anschliessen eines
    Wechseldatenträgers die "Eingabeaufforderung, um Aktion auszuwählen" automatisch aufgerufen wird?


    Bin für jeden Hinweis dankbar und schon am verzweifeln.


    Danke.



    Gruss
    meute

  • Nun stellt sich die Frage, ob das mit den gleichen Geräten(Sticks oder Digi) beim jeweiligen Schlepper so ist.


    USB-Massenspeicher wie z.B. Kameras findest Du in der Reg unter...


    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBSTOR


    ...vergleich mal die Regs von 2 unterschiedlich eingestellten Schleppern.


    Denke aber nicht, das da der Fehler liegt.
    Sehe, Du hast ja schon ne Menge angestellt und will nur mal posten wie es bei nem anderen User läuft.


    Habe Zeit heute für sowas :lol: und das mal nachgestellt(ja hat schon etwas gedauert) :mad: mit nem Medion, Gericom und nem HP Schlepper sowie einem Desk-PC und einer Olympus C-40, da hab ich aber nur die eine.


    Bei allen das Gleiche...


    Rechts aufs LW nach der Erkennung als WD-Träger und nacheinander die jeweiligen Autoplays eingestellt Alles auf "Eingabeaufforderung, um Aktion auszuwählen" und auch wieder zurück(Aktion festgelegt) per Übernehmen oder gleich OK. Jedesmal wurde die eingestellte Funktion danach bei neuem Einstecken ausgeführt.
    Allerdings habe ich bei allen Rechnern unter...
    Eigenschaften->Hardware->Gerät->Eigenschaften->Richtlinien->"Für schnelles Entfernen optimieren" eingestellt. Gibt es da Unterschiede?


    Zitat

    Wie lautet der Befehl, mit dem nach anschliessen eines
    Wechseldatenträgers die Ordneransicht automatisch aufgerufen wird?


    Wie lautet der Befehl, mit dem nach anschliessen eines
    Wechseldatenträgers die "Eingabeaufforderung, um Aktion auszuwählen" automatisch aufgerufen wird?


    Meines Wissens als direkten Befehl so nicht. Denke das ist im Explorer oder Treiber hinterlegt.


    Mehr kann ich da nun leider auch nicht mehr zu sagen. :(

    hope dies last


    tschöö... ast

  • hi...



    ast:

    Zitat

    Mehr kann ich da nun leider auch nicht mehr zu sagen.


    tztztztz...
    folgendes passt aber bestimmt noch in deine sammlung... ;)


    die autostartfunktion lasst sich für jedes laufwerk einzeln überarbeiten:


    registrierungsdatenbank starten:
    start ---> ausführen ---> regedit + OK


    und folgender schlüssel suchen:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Policies\Explorer\NoDriveTypeAutoRun



    vom eintrag NoDriveTypeAutoRun muss nun der wert geändert werden:
    1 deaktiviert den Autostart für unbekannte Laufwerkstypen,
    2 unbekannt/nicht dokumentiert,
    4 deaktiviert den Autostart für wechselbare Datenträger (z.B. Diskettenlaufwerk),
    8 deaktiviert den Autostart für feste Datenträger,
    16 deaktiviert den Autostart für Netzwerklaufwerke,
    32 deaktiviert den Autostart für CD-ROM,
    64 deaktiviert den Autostart für die RAM-DISK,
    128 reserviert und immer gesetzt.


    Um mehrere Laufwerke zu sperren mussen entsprechende werte zusammengerechnet werden und in HEX-FORMAT umgerechnet werden.


    Kleine bemerkung noch: hexadezimale werte mussen immer in zweistelliger form eingetragen werden nach dem beispiel 12 34 56 78




    gruss...




    franky...

  • Hallo ast,
    hallo n.a.,


    zuest mal danke für Eure Antworten.


    Ich hatte am WE einen längeren Thread auf forum.popbu.de mit jemanden. Der hat es am WE für mich getestet, weil ich kein XP da hatte.


    Das Problem ist, dass die Eingabeaufforderung (Assistent) anscheinend nur erscheint, wenn auf dem Datenträger entweder Bilder, Musik, Filme oder alles drei gemischt vorhanden ist.


    Dieses habe ich nun auch bei mir getestet und konnte das verhalten genau so nachvollziehen.


    Nur bei einem NB (denke ich), habe ich letzte Woche die Kamera mit Bilder angesteckt und es kam trotzdem die Ordneransicht.
    Dieses NB muss ich aber noch testen. Mal sehen was passiert. Wenn es rumzickt, werde ich mal alle USB-Geräte deinstallieren.


    Hier der Link zu dem Thread:
    http://forum.popbu.de/thread.p…18d709bf1ce&page=1#11



    Gruß
    meute

  • Zitat von meute

    Autoplay funktioniert also...


    Autoplay soll/muss dabei doch laufen.


    Franky??? Hallo??? Too much tea???




    Zitat von n.a.

    tztztztz...
    folgendes passt aber bestimmt noch in deine sammlung...


    Das ist schon drin, war aber nicht gewünscht. :twisted::twisted:


    Gibt es eigentlich auch Karottentee :?:


    *jetztabernüschtwiewech* :twisted::twisted::twisted:

    hope dies last


    tschöö... ast