Icon_Excel10_33x32Müssen in einer Excel-Tabelle mehrere Spalten miteinander verglichen, und gezielt Werte herausgesucht werden, ist das im Gegensatz zu dem SVERWEIS mit einer Kombination aus INDEX- und VERGLEICH-Funktion sehr komfortabel möglich. Bei einem SVERWEIS müssen die Spalten immer eine bestimmte Anordnung zueinander haben. Die INDEX-Funktion kann innerhalb einer Matrix alle beliebigen Spaltenkombinationen anfahren.

 

Mit einem kleinen Beispiel sollen die beiden Funktionen INDEX und VERGLEICH einmal unabhängig voneinander und einmal ineinander verschachtelt beschrieben werden.

 

1. INDEX()-Funktion

Ein Anwendungsfall für die INDEX-Funktion ist Folgender:  Man möchte aus einer bestimmten Matrix bzw. der kompletten Tabelle immer eine bestimmter Zellenwert ausgegeben haben.

=INDEX(Matrix;Zeile;Spalte)

Also sieht die INDEX-Funktion für die Zelle aus der vierten Zeile und dritten Spalte so aus:

=INDEX(A1:D8;4;3)

2_INDEX

 

2. VERGLEICH()-Funktion

Die VERGLEICH-Funktion sucht aus einer Spalte einen vorgegebenen Wert und gibt dann die Zeile aus, in der der Wert steht.

=VERGLEICH(Suchkriterium;Suchmatrix;Vergleichstyp)

Für eine genaue Übereinstimmung gibt man für den Vergleichstyp eine Null ein.

Sucht man also die Zeile, in der der Maximalwert der zweiten Spalte steht, sieht die Funktion so aus:

=VERGLEICH(MAX(B1:B8);B1:B8;0)

3_VERGLEICH

 

3. INDEX- und VERGLEICH-Funktion verschachtelt

Wirklich interessant wird es eigentlich dann, wenn man die beiden Funktionen ineinander verschachtelt. Auch dann erst ist der Vorteil für einige Fälle im Vergleich zu dem SVERWEIS zu erkennen.

Für dieses Beispiel wurde eine neue Tabelle gewählt.

Es soll nun die Mitgliedsnummer einer bestimmten Person ausgegeben werden. Bei einem SVERWEIS müsste die Spalte dafür rechts von der vierten Spalte liegen. Dies ist hier nicht erforderlich.

=INDEX(A2:D8;VERGLEICH("Tim";D2:D8;0);2)

4_verschachtelt

 

___________________________________________________
Dieser Tipp stammt von www.win-tipps-tweaks.de
© Copyright Michael Hille/Chainon Kittisonthirak

Warnung:
Die unkorrekte Verwendung des Registrierungseditors oder der Tipps kann schwerwiegende Probleme verursachen, die das gesamte System betreffen und eine Neuinstallierung des Betriebssystems erforderlich machen. Eingriffe in die Registrierungsdateien und die Anwendung der Tipps erfolgen auf eigenes Risiko.

 

Letzte Forenbeiträge

  • Office-Monitor für 100€?
    Also wenn du noch ein wenig mehr Geld zur Verfügung hast, sagen wir etwa 50 €, so wirst du schon einige höhenverstellbare Office-Monitore finden....
  • Windows 10 vs. Linux?
    Ich habe mich auch mal mit Linux probiert, bin aber im Endeffekt wieder bei Windows gelandet. Ich würde einfach mal sagen, probiere es doch einmal...
  • Windows 10 gut oder schlecht?
    Also ich bin mit Windows 10 voll und ganz zufrieden. Klar hat es hier und da einige Probleme, aber so ist Technik nun mal. Vor allem wenn man es mit...
  • Googles Top Suchanfragen Deutschland 2018
    Vielleicht tun sie es ja schon....

    Gruß
    Manni
  • Verkaufe PS2 Games ..
    Hallo
    Wenn jemand Spiele auf PS2 hat, werde ich kaufen
    mein kind liebt es auf ps2 zu spielen

/** * */