Probleme mit Programm auswählen...

  • Hallo zäme


    Ich habe in meinem Windows XP Rechner folgendes Problem entdeckt.


    Wenn ich eine Bild oder Audio-Datei mit Rechtsklick anwähle öffnet sich ein Kontextmenü. Da gehe auf öffnen mit dort sind wieder mehrere zu Auswahl und zuunterst der Eintrag Programm auswählen... Hier öffnet sich bei mir der Editor mit zum Teil komischen Schriftzeichen und von Programm auswählen keine Spur. Wenn ja, wie und wo kann ich das wieder zurückstellen oder öffnet sich bei allen wo z.B. SP2 installiert haben der Editor?


    Vielen Dank und Grüsse


    Erich

    Wo ein Wille da ein Weg! Rechte beim Autor ansonst bei mir

  • Hallo Erischa.


    Vermutlich hast du einmal als die Meldung kam darauf geklickt immer diese Datei mit dem Programm öffnen so das jetzt immer der Editor gestartet wird.
    In den Ordneroptionen suchst du dir unter Dateitypen diese Dateien aus und änderst das Programm zum Öffnen.


    Gruß Peter

    Birsctihe Frshocer hbaen haruesgfnuedn, dass es eagl ist, in whlecer Rhieenfgloe die Behsucbatn eenis Wtores sheten, slognae der etsre und ltetze Bhsucbate am rhitirgcn Pltaz sehten.

  • Hallo Peter!


    Ich verstehe deine Antwort nicht ganz. Da wo ich meine müssten eigentlich alle Programm erscheinen die ich auf dem Rechner habe siehe Bild


    [Blockierte Grafik: http://Erischa.webspace4free.biz/Web/Editor.GIF]


    da wo ich rot eingekreist habe sollten doch Programme aufgehen und nicht der Editor. Ich nehme an das dies in der Registry geändert wird weiss aber nicht wo?
    Wäre froh wenn mir jemand weiter helfen könnte.


    Gruss Erich

    Wo ein Wille da ein Weg! Rechte beim Autor ansonst bei mir

  • Hallo Leute!


    Gibt es denn da niemand wo mir sagen kann wie ich mein Problem lösen kann?


    Zitat

    Wenn ich eine Bild oder Audio-Datei mit Rechtsklick anwähle öffnet sich ein Kontextmenü. Da gehe auf öffnen mit dort sind wieder mehrere zu Auswahl und zuunterst der Eintrag Programm auswählen...


    (siehe auch Bild in Beitrag weiter oben)
    statt weiterer Programme zum auswählen öffnet sich der Editor.


    Vielen Dank und Gruss


    Erich

    Wo ein Wille da ein Weg! Rechte beim Autor ansonst bei mir

  • Hallo Erischa.


    Gehe mal in den Ordneroptionen >> Dateitypen
    Dort kannst du auswählen welche Datei du mit welchen Programm öffnen willst.
    Du hast Recht (bei deinem Bild) normalerweise müsste dort dann die Auswahl kommen welche Programme du zum Öffnen auswählen willst und nicht automatisch der Editor.


    Gehe mal in die Registry zu diesem Schlüssel:


    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Unknown


    Bei mir sieht der so aus:
    Anfang
    REGEDIT4


    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Unknown]
    "AlwaysShowExt"=""
    "QueryClassStore"=""


    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Unknown\shell]
    @="openas"


    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Unknown\shell\openas]


    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Unknown\shell\openas\command]
    @=hex(2):25,53,79,73,74,65,6d,52,6f,6f,74,25,5c,73,79,73,74,65,6d,33,32,\
    5c,72,75,6e,64,6c,6c,33,32,2e,65,78,65,20,25,53,79,73,74,65,6d,\
    52,6f,6f,74,25,5c,73,79,73,74,65,6d,33,32,5c,73,68,65,6c,6c,33,\
    32,2e,64,6c,6c,2c,4f,70,65,6e,41,73,5f,52,75,6e,44,4c,4c,20,25,\
    31,00 Ende


    Ohne das "Regedit 4".
    Wenn du willst kannst du ihn von Wort Anfang bis Wort Ende in eine Textdatei kopieren (Anfang und Ende dann weglassen) und diese Datei dann umbenennen in *.reg und kannst sie einfach mit einen Rechtsklick bei dir eintragen. Hoffe dies hilft dir.


    Gruß Peter

    Birsctihe Frshocer hbaen haruesgfnuedn, dass es eagl ist, in whlecer Rhieenfgloe die Behsucbatn eenis Wtores sheten, slognae der etsre und ltetze Bhsucbate am rhitirgcn Pltaz sehten.

  • Hallo Peter
    Vielen Dank für die Hilfe
    Mit der Registry frage ich sicherheitshalber nochmals nach




    Zitat

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Unknown]
    "AlwaysShowExt"=""
    "QueryClassStore"=""


    sieht bei mir so


    aus[Blockierte Grafik: http://Erischa.webspace4free.biz/Web/unknow.gif]


    ohne Werte und der Nächste


    Zitat

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Unknown\shell]
    @="openas"



    [Blockierte Grafik: http://Erischa.webspace4free.biz/Web/shell.gif]


    [Blockierte Grafik: http://Erischa.webspace4free.biz/Web/openas.gif]


    und der letzte


    Zitat

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Unknown\shell\openas\command]
    @=hex(2):25,53,79,73,74,65,6d,52,6f,6f,74,25,5c,73,79,73,74,65,6d,33,32,\
    5c,72,75,6e,64,6c,6c,33,32,2e,65,78,65,20,25,53,79,73,74,65,6d,\
    52,6f,6f,74,25,5c,73,79,73,74,65,6d,33,32,5c,73,68,65,6c,6c,33,\
    32,2e,64,6c,6c,2c,4f,70,65,6e,41,73,5f,52,75,6e,44,4c,4c,20,25,\
    31,00 Ende


    [Blockierte Grafik: http://Erischa.webspace4free.biz/Web/command.gif]


    mit dem Wert


    Code
    1. %SystemRoot%\system32\rundll32.exe %SystemRoot%\system32\shell32.dll,OpenAs_RunDLL %1


    Also abschliessend wenn das

    Code
    1. %SystemRoot%\system32\rundll32.exe %SystemRoot%\system32\shell32.dll,OpenAs_RunDLL %1


    gegen dies tausche löst sich mein Problem


    Code
    1. (2):25,53,79,73,74,65,6d,52,6f,6f,74,25,5c,73,79,73,74,65,6d,33,32,\
    2. 5c,72,75,6e,64,6c,6c,33,32,2e,65,78,65,20,25,53,79,73,74,65,6d,\
    3. 52,6f,6f,74,25,5c,73,79,73,74,65,6d,33,32,5c,73,68,65,6c,6c,33,\
    4. 32,2e,64,6c,6c,2c,4f,70,65,6e,41,73,5f,52,75,6e,44,4c,4c,20,25,\
    5. 31,00


    Bitte um Bestätigung oder Korrektur


    Viele Dank und Grüsse


    Erich

  • Hallo


    Leider ist das Problem immer noch nicht gelöst
    Habe alles in den Wert kopiert siehe Code

    Code
    1. (2):25,53,79,73,74,65,6d,52,6f,6f,74,25,5c,73,79,73,74,65,6d,33,32,\
    2. 5c,72,75,6e,64,6c,6c,33,32,2e,65,78,65,20,25,53,79,73,74,65,6d,\
    3. 52,6f,6f,74,25,5c,73,79,73,74,65,6d,33,32,5c,73,68,65,6c,6c,33,\
    4. 32,2e,64,6c,6c,2c,4f,70,65,6e,41,73,5f,52,75,6e,44,4c,4c,20,25,\
    5. 31,00


    Bei Name steht Nichts(Standard), der Tip ist REG_ESPAND_SZ


    Alter Wert war

    Code
    1. %SystemRoot%\system32\rundll32.exe %SystemRoot%\system32\shell32.dll,OpenAs_RunDLL %1


    Für alle weiterführende Hilfe schonmal ein Danke mit den besten Grüssen Erich

    Wo ein Wille da ein Weg! Rechte beim Autor ansonst bei mir

  • Tag Erich,
    die erste Anlaufstelle ist Ordneroption-Dateitypen.Markiere den Dateityp MP3,der sich zum Beispiel mit dem Editor öffnet und gehe in die Erweiterung.Im Aktionsfeld müssen open und play stehen.
    Open hat folgende Bedeutung unter XP.
    Die Liste "Programme" ist in XP in 2 Gruppen aufgeteilt.Empfohlene Programme-Andere Programme.
    Zur Verwaltung der zweiten Gruppe greift XP auf einige Schlüssel im Zweig HKCR und nicht HKLM,denn XP erzeugt die Liste "Andere Programme",indem es den Schlüssel HKCR\Applications auswertet.
    XP überträgt dann Einträge,die das kanonische Verb "open" enthalten,automatisch in den Unterschlüssel Applikations,sobald Du eine Anwendung auf diese Art öffnest.
    Bleiben wir bei MP3 als Beispiel,die mit dem Media Player abgespielt wird.
    In HKCR\Applications findest Du Exe's für die Liste "Andere Programme".
    Auch die wmplayer.exe.
    Im Unterverzeichnis begegnest du der shell...mit dem Eintrag play .
    Darunter das Verzeichnis "open....Wert....öffnen
    Darunter command....."C:\Programme\Windows Media Player\wmplayer.exe" /open "%L"
    Das nächste Unterverzeichnis der shell ist play mit dem Eintrag play.
    Darunter command...Wert..."C:\Programme\Windows Media Player\wmplayer.exe" /Play "%L"


    Alternativ läßt sich das Ganze auch in HKCR bearbeiten.
    Suche mp3 und öffne es.
    Darunter setzt Du das Unterverzeichnis "OpenWithList" und unterhalb den neuen Eintrag "wmplayer.exe" ohne Wert.
    Wichtig wiederum,dass die Anwendung zusätzlich in "Applikations" registriert ist,damit sie in der Öffnen-mit-Liste auftaucht.


    Auch wenn ich kein geübter Forenschreiber bin hoffe ich,daß ich Dich einwenig in die Geheimnisse der Datenregistierung führen konnte.


    In der Ordneroption soll "play" als Standard stehen.
    Die Anführungszeichen müssen wegen den Leerstellen gesetzt werden.


    Gruß Bit

  • Hallo Erischa.


    Dein alter Wert habe ich gelesen wird dazu genutzt um das Auswahlfeld "Datei immer mit diesem Programm öffnen.." zu deaktivieren. Hast du irgend ein Tool benutzt oder sonstiges getan was annähernd damit zu tun hat?
    Versuche mal diesen Schlüssel:


    HKEY_CLASSES_ROOT\Unknown\shell\Open\Command\
    Erstellst du eine neue Zeichenkette und teilst ihr diesen Wert zu:
    C:\Windows\notepad.exe %1


    Jetzt müsste doch hoffentlich das Problem gelöst sein.
    Erwarte Antwort.


    Gruß Peter

    Birsctihe Frshocer hbaen haruesgfnuedn, dass es eagl ist, in whlecer Rhieenfgloe die Behsucbatn eenis Wtores sheten, slognae der etsre und ltetze Bhsucbate am rhitirgcn Pltaz sehten.

  • Hallo Peter & Bit


    Bit
    Ich war mal in den Ordneroption in mp3 da steht öffnen mit Realone Player bei erweitert Aktion open. Wenn statt erweitert auf ändern klicke erscheint genau das Bild wo ich bei Programm auswählen vermisse. Sorry Bit aber dem Rest wo wie und was ich da ändern soll versteh nichts mehr? Ist das in den Ordneroption oder in der Registry?


    Das Problem ist ja überall also nicht nur bei mp3 da sollte es schon eine einfachere Lösung als jede Erweiterung zu korrigieren geben.


    Leider kein Erfolg


    Peter

    Zitat

    HKEY_CLASSES_ROOT\Unknown\shell\Open\Command\
    Erstellst du eine neue Zeichenkette und teilst ihr diesen Wert zu:
    C:\Windows\notepad.exe %1


    bei mir stand an der Stelle: notepad.exe "%1" habe es mit altem Wert wieder versucht und mit deiner langen Zahlenreihe alles ohne Erfolg.
    Ja noch was bei meinem Wert waren %1 zwischen 2" (Gänsefüsschen) ist das wichtig? Habe ich dann raus gestrichen.


    Gruss Erich


    PS Habe letztends mal Tipps und Tricks durchgeführt. Kann schon sein das ich da mal was verändert habe.

    Wo ein Wille da ein Weg! Rechte beim Autor ansonst bei mir

  • HKCR=HKEY_CLASSES_ROOT in der Registrey und Applications ist ein Verzeichnis.Alle Exe's darin kannst Du mit "Programme auswählen" abrufen, wenn das Unterverzeichnis eine "shell" mit dem Unterschlüssel "command" beinhaltet.In unserem Beispiel muss in diesem Ordner die Player.exe,welcher auch immer,den Pfad zu dieser exe beinhalten.
    Alle Exe-Einträge mit dem Hinweis "NoOpenWith" ohne shell-open-command- Ordner,erscheinen dann nicht in der "Öffnen mit-Liste".


    Der "Unknown-Schlüssel" in HKCR hat folgenden Aufbau:
    Unknown:
    Rechtes 2 REG_SZ Einträge
    AllwaysShowExt
    QueryClassStore
    Darunter die Shell
    Rechts....Standard....REG_SZ....der Wert = openas
    Darunter open
    Rechts...Standard...REG_SZ...Wert...Öffnen mit...
    Darunter command
    Rechts...Standard...REG_SZ..Wert...rundll32.exe shell32.dll,OpenAs_RunDll %1


    Versuche es mal.


    Bit

  • Jetzt habe ich in Unknown glatt einen Schlüssel unterschlagen.


    openas
    Rechts...Standard...REG_SZ...Wert...Programm auswählen...
    darunter
    command...Standard...REG_SZ...Wert...rundll32.exe shell32.dll,OpenAs_RunDll %1


    Sorry
    Bit

  • Hallo


    Bit
    Leider hat es das Problem auch nicht gelöst.


    Habe nun TuneUp Utilities/ Anpassen & Informieren/ TuneUp SystemControl/ Ordneroption/ Anzeige gestartet. Wo ich dann auf Standartwert wiederherstellen klickte und siehe da jetzt bin ich wieder zufrieden mit der Darstellung Programme auswählen.


    Habe dann auch wieder meinen alten Wert %SystemRoot%\system32\rundll32.exe %SystemRoot%\system32\shell32.dll,OpenAs_RunDLL %1 zurückkopiert und es ging immer noch.


    Leider kann ich nicht sagen was genau verändert wurde in der Registry nur eines TuneUp kann ich wirklich empfehlen.


    Gleichwohl ein grosses Dankeschön an alle die Mitgeholfen haben das Problem zulösen.


    Gruss Erich


    PS. Das nächste folgt sicher

    Wo ein Wille da ein Weg! Rechte beim Autor ansonst bei mir

  • Tag Erich,
    da werden sich aber einige Toolfreunde die Händer reiben. ;-)
    Der Nachteil,wir wissen nicht an was es lag.
    Wenn einige Deiner Dateien mit dem Verb "open" nicht mit der Exe der jeweiligen Anwendung verknüpft war,sondern mit dem Editor,dann öffnet sich MP3 natürlich als Datei als solche und zeigt Dir wirre Zeichen.
    Das Tool stellte nur die richtig Zuordnung wieder her.


    Wenn in "Unknown" ein Fehler vorliegt,dann wird der Dialog "Programm Auswählen" auch nicht ausgeführt.Darum der Hinweis auf diesen Schlüssel.


    Hi Peter, Mitkämpfer an der Front:Wir wurden von einem Tool geschlagen.:-) Das ist natürlich ein völliger Egoverlust. ;-)


    Frohe Oster
    Bit

  • Hallo Peter & Bit


    Ist es möglich das ihr vielleicht zu weit nach Lösungen gesucht habt. Mit dem öffnen der Programme im Kontextmenu direkt ging ja tadellos. Es hatte ja immer eine unterschiedliche Anzahl zur Auswahl je nach Datei. Nur in der Zeile Programme auswählen... erschien ja der Editor.
    Hoffe auf dem Weg ein bisschen zur Lösung beizutragen.


    Frohe Ostern wünscht euch


    Erich

  • Hi Erich,
    Ich hatte Deinen Fehler schon verstanden.Die Schlüssel in der Registry "Applications" und "Unknown" hängen mit "Programm auswählen" zusammen.In Beiden besteht die Möglichkeit, "Programm auswählen" so zu lancieren,um alle Dateien mit einer Anwendung starten zu lassen.
    Dies kann bewusst eingestellt werden,oder durch ein Ereignis mit einer Installation.
    Das Thema "Dateitypen registrieren" in Verbindung mit "Öffnen mit und Programm auswählen" ist sehr komplex und mit viel Fußangeln versehen.
    Da ich ein alter Registryfummler bin,hätte mich die Ursache interessiert.
    Leider läuft mein System perfekt und bin daher auf die Downs Anderer angewiesen. :-) Freue mich natürlich,dass bei Dir alles wieder Paletti ist.


    Bit