Concurrent Sessions

  • Ich habe mir mal den Workshop Beitrag http://www.xp-tipps-tricks.de/page-132.html angesehen.
    Leider gibt es da im Prinzip keinerlei Beschreibung dazu, wozu das überhaupt sein soll bzw. was man damit machen kann.
    Für mich klang das sol, als wenn ich mich gleichzeitig über REMOTEDESKTOP auf dem Rechner anmelden könnte und dann BEIDE,. also der REMOTE und der User LOKAL weiterarbeiten könnten.
    Genau das geht aber auch weiterhin nicht.


    Deswegen zwei Fragen.
    1. Wozu soll das Concurrent Sessions aus dem Workshop gut sein.
    2. Kennt einer eine möglichkeit, RemoteDesktop zu verwenden und beide können angemeldet bleiben und mit dem Rechner arbeiten.
    Und bitte keine Zusatzprogramme wie das Teil von Norton oder andere Fernwartungssoftware. Es sollte mir Remotedesktop gehen.

  • Laut MS kann bei Remote-Dektop (TSC früher) nur einer mit dem Ding arbeiten, nicht zwei gleichzeitig.


    Das soll wohl mit dem Workshop und der "älteren" Datei machbar sein.


    Ich hab mich damit aber noch nicht beschäftigt und daher ist es erstmal nur so als Info zu verstehn.


    Der Unterschied ist auch das die Größen der termsrv.dll Versionen eklatant auseinander gehen.


    Nicht schmollen jetzt, nur mal gefragt.


    Remote ist freigeschaltet, gestartet und läuft sonst? Anmelden geht, oder wie?
    Desk in fine black mit Logon-Maske da?
    Sonst haste ja erstmal eh noch einzurichten.

    hope dies last


    tschöö... ast

  • Jup, RemoteDesktop war schon bei mir eingerichtet und lief UND läuft auch immer noch prima.
    Aber sobald ich mich eben mit einem zweiten Rechner einlogge, geht auf dem anderen Rechner zurück zum Anmeldebildschirm.
    Tja, und wenn ich mich da anmelde, fliegt der andere raus.
    So, wie bisher halt leider auch.


    Ich hatte das auch so Verstanden, das man an seinem Rechner arbeiten kann und sich ein zweiter GBLEICHZEITIG einloggen und auch damit Arbeiten kann. Hmmm, moment mal. Ich glaub, ich hab da aber was falsch gemacht. Sekunde.


    Ne, doch nicht. Ich dachte schon, weil ich nur ein Benutzerkonto hatte. Hab aber gerade ein zweites angelegt und mich dann damit angemeldet, aber geht auch net.


    Bei der Gelegenheit habe ich aber festgestellt, das die neue Datei termsrv.dl_ in Englisch ist. Toll, auf sowas steh ich. :-(



    Naja, jedenfalls funktioniert es nicht.
    Sonst noch jemand ne Idee dazu ?

  • Das funzt ganz Prima, sofern du die anleitung korrekt umgesetzt hast.


    Du MUSST zwei unterschiedliche Benutzer anmelden. Ansonsten wird die Session des Angemeldeten Users übernommen.
    BenutzerA auf Konsole
    BenutzerB per Terminaldienste.
    Beider sollten Admin oder zumindest in der Gruppe Remotedesktopbenutzer sein.


    Verwendungszweck: Musik auf der Konsole, Email etc per Remote.
    Läuft just in diesem Moment so auf meinem Lap.


    Gruß
    Tobias

    Ihr aber, wenn es so weit sein wird
    Daß der Mensch dem Menschen ein Helfer ist
    Gedenkt unserer
    Mit Nachsicht.


    (Berthold Brecht - An die Nachgeborenen)

  • Ich habe mich genau an die Anleitung gehalten, soweit das möglich war.
    Auf RechnerA im Verzeichnis Windows/System32 die Datei ersetzt.
    Im Verzeichnis System32/dllcache die Datei ersetzt.
    Ein Verzeichnis "Servicepackfiles" habe ich auf diesem Rechner aber gar nicht.
    Dann die beiden Einträge in der Registery geändert bzw. hinzugefügt und den Wert auf 1 gesetzt.


    Damit klappt es dann aber nicht.


    Also habe ich auf meinem Notebook ebenfalls die änderungen durchgeführt.
    Im Verzeichnis System32 die Datei ersetzt.
    Im Verzeichnis System32/Dllcache existiert diese Datei erst gar nicht, aber ich habe die dann mal rein kopiert.
    Dieser Rechner hat auch ein Verzeichnis ServicePackFiles, aber nicht wie angegeben im Ordner System32, sondern direkt im Windows Ordner.
    Da ist die Termsrv.dll aber auch nicht drin vorhanden und ich habe die auch nicht rein kopiert.


    So, dann noch die Registery angepasst und auch beide Rechner neu gebootet. Auf beiden Rechnern ist die Termsrv.dll im System32 Verzeichnis nun 210 KB groß, die originale war 290 KB groß. Also hat der Austausch auch funktioniert.


    Nun starte ich auf dem Notebook RemoteDesktop und gebe als Ziel 192.168.x.x (RechnerA) an udn als Benutzername den zweiten Account, der auch Admin rechte hat.
    Dann einmal VERBINDEN geklickt.
    Und dann kommts:
    "Der Benutzer RechnerA\xxxxxx ist momentan an diesem Computer angemeldet, xxxx muss vom Computer getrennt werden. Möchten Sie den Vorgang vortsetzen ?"


    Natürlich will ich das nicht, das er getrennt wird, aber ich muss ja trotzdem JA klicken. Hilft ja nix.


    Tja, dann bekomme ich auf RechnerA noch die ENGLISCHE Meldung, im Prinzip das selbe, wie oben.


    Wenn ich da auch JA sage bzw. einfach etwas warte, dann kann sich der Notebook mit seinem Accout anmelden, aber der RechnerA wird eben abgemeldet. Melde ich mich mit RechnerA einfach wieder an, wird der Notebook rausgeschmissen.


    Und nu ?
    Sag jetzt nicht, ich soll extra alle Verzeichnisse anlegen, die da in der Anleitung genannt werden. Ich denke, wichitg ist, das die Datei im SYSTEM32 die richtige ist und das sieht man ja anhand der Dateigröße, das sie das ist.

  • Zitat

    Sag jetzt nicht, ich soll extra alle Verzeichnisse anlegen, die da in der Anleitung genannt werden. Ich denke, wichitg ist, das die Datei im SYSTEM32 die richtige ist und das sieht man ja anhand der Dateigröße, das sie das ist.


    doch...
    steht doch in der anleitung, an welcher du dich gehalten hast, das die datei in alle 3 verzeichnisse rein muss...
    auch ist es eine grundsatzbedingung das SP2 auf beide rechner vorhanden ist...


    noch mal zu erlauterung : dieses feature wird von ms nicht unterstützt oder supported... es wurde wieder aus das sp2 herausgenommen...
    ich habe es euch nur angeboten mit ein kleiner info-workshop dazu, weil ich es bereits seit rc1 für sp2 einsetze...


    sicherheitstechnisch ist momentan keine lücke an der prozedure bekannt, allerdings wird dieses feature von den sicherheitsspezialisten auch nicht weiter getestet...


    wann du der anleitung folgst, und auch sts.metamensch seiner hilfe (userkonten) auffolgst sollte es tadellos funzen...


    es MUSSEN aber 2 verschiedene konten gleichzeitig sein...



    gruss...




    franky...

  • Gut, Spaßeshalber mal das Verzeichnis System32/ServicePackFiles/i386
    angelegt und die termsrv.dll mit 210,5 Kb da rein kopiert.
    Die ist auf RechnerA nun also drei mal vorhanden.
    System32
    System32/dllcache
    System32/ServicePackFiles/i386


    wobei ich immer noch meine, das letzteres nicht nötig ist, da mein ServicePack2 fest auf der Windows CD drauf ist und der Rechner auch so installiert wurde. Demnach also noch gar kein ServicePack nachträglich installiert wurde und Windows deswegen diesen Ordner auch nicht angelegt hat.
    Aber egal. Habs halt mal gemacht, Ergebnis bleibt das selbe. Es geht nicht.


    Übrigens. In der Anleitung steht NICHT, das die Datei in alle drei Verzeichnisse MUSS, sondern SOLLTE. Lies nochmal nach. :-)


    Tja, wie gesagt. Geht nicht, obwohl ich zwei Konten habe. Er will immer noch der gerade aktiven Benutzer abmelden bzw. tut es den auch.



    PS: Wenn DU zweifel daran haben solltest, meld dich mal via. MSN bei mir, dann gewähre ich Dir Remotezugriff und Du kannst selber mal nachsehen.

  • gucke mal in den tipps nach verbindung bei benutzerwechsel nicht unterbrechen...


    etwas scheint bei dir lokal die sessions zu blockieren...
    irgendwelcher dienst zum thema netzwerk vl... ???


    ich habe bei mir die termsrv.dl_ im unattend intergiert, ebenso wie die reg-änderungen...
    hatte mir eigentlich denken können das du auch eine unattend hast... :lol:



    gruss...




    franky...

  • "Die Suche hat 4885 Ergebnisse ergeben "


    LOL
    Ich glaub, das war nix.
    Mal sehen, ob ich die Suche weiter einschränken kann.


    "Die Suche hat 296 Ergebnisse ergeben. "


    Puh, das, wenn ich nach "verbindung benutzerwechsel" suchen lasse.


    Ah hier. "Dfue - Verbindung bei Benutzerwechsel nicht trennen"
    Tja, nur hat das Problerm ja nix mit der DFÜ Verbindung zu tun.
    1. bleibt die bei mir eh aktiv.
    2. bin ich ja LOKAL mit dem anderen Rechner verbunden.


    Ich habe mir den Registery EIntrag dann aber trotzdem mal angesehen und der ist bei mir schon vorhanden und auch auf 1 gesetzt.


    Das kann es also auch nicht sein.



    Wie kommst Du da drauf, das bei mir irgendwer die Session blockiert ?
    Remotedesktop klappt ja soweit problemlos. Ich kann mich mit beiden Accounts jederzeit anmelden. Aber eben immer nur mit einem gleichzeitig.

  • Zitat

    Wie kommst Du da drauf, das bei mir irgendwer die Session blockiert ?


    weil es bei mir und verschiedene andere leute auch funzt...
    1. ich habe die anleitung ausführlich probiert...
    2. auch im msfn-forum wird über diesen vorgang berichtet... gleiche anleitung...
    3. zb sts.metamensch hat schon berichtet das es funzt...


    das nur ein benutzer gleicherzeit angemeldet sein kann bei dir ist ein lokales problem, weil die registry-einträge im workshop sind nähmlich da um multiple-zugriff zu erlauben... ;)



    gruss...




    franky...

  • Mach mal start - ausführen - gpedit.msc und guck da unter Computerkonfiguration - Administrative Vorlagen - Terminaldienste die Einstellungen durch. Vielleicht hast du eine Richtlinie aktiviert die nur einen User erlaubt, dann würden auch die reg-keys nichts helfen.
    Am Besten stellst du ALLES auf nicht konfiguriert (wenns net schon so ist)


    Gruß
    Tobias



    PS @anky: War net von Paul Thurrott damals beim RC1 dat Feature zu posten.... Aber ich fand Deien Anleitung besser. Thx nochmal.

    Ihr aber, wenn es so weit sein wird
    Daß der Mensch dem Menschen ein Helfer ist
    Gedenkt unserer
    Mit Nachsicht.


    (Berthold Brecht - An die Nachgeborenen)

  • So, GPEDIT hatte ich dann mal durchgeackert. Stand alles auf "Nicht Konfiguriert".
    Naja, die Windows Indtallation ist relativ frisch. Gerade mal nen Monat alt. Da dürfte eigentlich noch nix verstellt sein. :-)


    @n.a.
    Ich habe die ANleitung auch ausführlich probiert. Trotzdem geht nix und ich weiß immer noch nicht, was Du unter einer "blockierten Session" verstehst. :-)


    Ich glaub Dir ja, das es bei anderen geht. Wundert mich eben nur, das es auf meiner relativ frischen Installation nicht geht.


    Mom, jetzt versuch ich einfach mal den umgekehrten weg, also vom Rechner zum Notebook. Mal sehen, ob das geht.


    Krass. So rum gehts.
    Schon komisch. Eigentlich sind beide Rechner soweit Identisch.
    Einzigster Unterschied, soweit ich mich entsinne. Der Notebook wurde mit Windows XP installiert und dann das SP2 nachträglich aufgespielt. Der Rechner wurde aber mit dem Windows XP inkl. SP2 installiert.
    Ob das wohl einen Unterschied macht ?


    Tja, wo soll man da jetzt anfangen zu suchen.
    Ich brauchs nämlich genau anders rum. Verdammt.

  • hi...



    mit blockierte session meine ich dass irgendwelcher dienst der unterstutzung von 2 simultane sessions blockiert...


    ob eine unattend ein problem stellen konnte, da sage/schreibe ich mal einfach nein, weil ich es auch so installiert habe und dabei einfach die termsrv.dl_ eingebunden habe...
    trotzdem habe ich den dritter ordner (service packfiles) angelegt...


    welcher dienst evt. blockieren könnte wird schwierig um zu raten, da es überhaupt keinen stsandard zum thema gibt, da ms dieses feature aus dem sp rausgenommen hat...
    und das obwohl es ein "supergeiles" feature ist...
    bin eigentlich mal gespannt ob es unter 2003 demnächst eingebaut wird...


    btw, zur sprache...
    es gibt keine deutsche version da alle sp-betareleases auf englisch waren (ausser sp2 und die zwischenversion 2138 glaube ich)... "leider" habe ich die nicht mehr auf der platte...
    kannst aber problemlos die sprachdateien mithilfe vom resource hacker austauschen...
    du hast doch noch die ausm sp2... ;)


    suche im registry vom laptop mal nach serverlist...
    sorry wann ich nicht mehr den genauen schlüssel kenne, aber sollte glaube ich im browser/parameter sein und deaktiviere das führen vom serverlist auf den schlepper...
    kannst auf den desktop evt. noch auf yes stellen, aber automatisch sollte reichen...
    vielleicht liegt da einfach ein problem das windows nicht genau weisst welcher als server eingesetzt werden soll, weil beide die gleiche versionsnummer haben...
    ist aber nur eine gedanke, weil ich weiss ja auch nicht wirklich was der grund für dein problem sein könnte... ich versuche also einfach "bekannte"
    probs unter netzwerke auszuschliessen... ;)



    Tobias:
    yep. habe ich auch gefunden...
    war was mir angeht ein der nutzlichste beiträge von paul thurrot im letzten jahr für den heimanwender...
    obwohl es vorher schon rumging im msfn-forum und auch bei winbeta...
    war schon nähmlich seit etwa betas inplementiert...
    thnx für die blumen... ;)


    hoffentlich kommen unsere weitere workshops und tipps auch so gut an...
    ist oft schon schwierig weil immer geschrieben werden muss für "standard-windows"... :twisted:



    gruss...




    franky...

  • Ah so. Das meinst Du mit "blockierter Session". :-)
    Ok, nur damit wir nicht aneinander vorbei reden.


    Den Ordner "ServicePackFiles" habe ich ja auch mal angelegt und die Datei da rein kopiert, hat aber leider nicht geholfen. :-(


    Ich habe die Termsrv.dl_ mit dem Link runtergeladen, der in dem Workschop angegeben ist. Die entpackte Datei ist 210.5 KB groß.


    Zitat

    suche im registry vom laptop mal nach serverlist...


    Gefunden


    Zitat

    sorry wann ich nicht mehr den genauen schlüssel kenne, aber sollte glaube ich im browser/parameter sein


    Volltreffer :-)


    Zitat

    und deaktiviere das führen vom serverlist auf den schlepper...
    kannst auf den desktop evt. noch auf yes stellen, aber automatisch sollte reichen...


    Jetzt wird es kompliziert.
    Es steht AUTO drin. Du sprichst zum einen von DEAKTIVIEREN, sagst aber auf AUTO oder YES stellen.
    Nun den., Ich habe mal NO eingegeben, selbes Ergebnis. Stelle jetzt wieder AUTO ein.



    So, ich habe gerade mal getestet, was passiert, wenn ich auf dem Notebook die Registery Eintreäge wieder auf 0 setze.
    Dann kann ich zwar ne Remotedesktopverebindung aufbauen, aber der Nutzer auf dem Notebook wird ohne Rückfrage abgemeldet.
    Soweit ja ok.
    Aber wenn ich ja mit dem Notebook auf den Rechner zugreifen will, wird der Benutzer ja nicht einfach abgemeldet, sondern es wird GEFRAGT, ob man den rauschschmeissen will. Das ist ja ein Unterschied, der uns ja zumindest einen kleinen Hinsweis gibt, wo das Problem liegen könnte.


    Ich durchsuche gerade mal alle Dateien im Windows Ordner nach dem Text "muss vom Computer getrennt werden". Vieleicht gibt mir das einen Hinweis, wo ich suchen soll.
    Shit, nichts gefunden.


    Au man. Ich habs.
    In der Registery war der Eintrag "EnableConcurrentSessions" wohl falsch geschrieben. Ich war mir sicher, der mit CUT & COPY aus dem Workshop so übernommen zu haben. Ich habe den sicher auch noch 20 mal kontrolliert.
    Gerade eben habe ich auf dem Notebook den Text mit CUT genommen, in eine Textdatei geschrieben und auf dem Rechner hier dann mittels COPY wieder eingesetzt und es geht.


    Das darf doch wohl nicht wahr sein.


    Sorry Jungs. Ich werde ab sofort immer meine Lesebrille aufsetzen, wenn ich am Computer bin.



    Danke nochmal an alle, die sich meinem Problem angenommen haben.

  • Hallo,
    Bin den Anleitungen gefolgt und es funktioniert auch soweit, dass sich mehrere Benutzer ueber Remotedesktop einloggen koennen, jedoch nicht mehr als 2. Kommt ein dritter ginzu, muss sich einer der beiden angemeldeten abmelden. Gibt es da eine Moeglichkeit, dies irgendwo einzustellen, z.B. Registry-Eintrag?


    Danke.

  • Schon versucht den AllowMultipleTSSessions Wert in der Reg höherzuschrauben?
    Zweiter Ansatz: Ausführen - gpedit.msc - Computereisntellungen - Administrative Vorlagen - Terminaldienste - Anzahl der Verbindungen einschränke
    Auf was du brauchst stellen. Experimentier sonst mal mit den restlichen Einstellungen da.


    Was den versuch mehr als 2 Ben. anzumelden angeht: denselben 2x geht nat. nicht :-) Dann muss einer raus und er andere übernimmt die Session. Lässt sich aber evtl auch über s.o. einstellen.


    Mach in Zukunft besser ein neus Thema für sowas, das hier mag best. kaum jemand ganz lesen.


    Gruß


    Tobias

    Ihr aber, wenn es so weit sein wird
    Daß der Mensch dem Menschen ein Helfer ist
    Gedenkt unserer
    Mit Nachsicht.


    (Berthold Brecht - An die Nachgeborenen)