Netzwerk unter XP pro und XP home - Dateifreigabe

  • Hallo Forum,


    habe schon ne ganze Weile gesucht und versucht das Ganze allein zu lösen, komme aber nicht weiter.


    Folgende Komfiguration:


    3 Rechner im Netzwerk, PC 1 XP pro, PC 2 XP pro, PC 3 XP home. Alle Rechner in der gleichen Arbeitsgruppe, auf allen Rechnern gleiche Benutzer.
    Alle sind über router/DSL ans Internet angebunden, funktioniert, erhalten IPs via DHCP vom router.


    Jetzt das Problem:
    Datei/Ordner "Eigene Dateien" (nur als Beispiel) wird auf allen drei Rechnern freigegeben, 2 verschiedene Benutzer (1 und 2) erhalten Zugriffsrechte, Benutzer "Jeder" fliegt raus.
    Nun versucht Benutzer 1 von PC 1 aus auf Ordner von PC 2 zuzugreifen: Funktioniert.
    Zugriff von PC 1 auf PC 3: nicht möglich.
    Von PC 2 auf PC 1: Funktioniert.
    Von PC 2 auf PC 3: nicht möglich
    Von PC 3 auf PC 1: funktioniert.
    Von PC 3 auf PC 2: funktioniert.


    Genau dasselbe Phänomen bei anderen Benutzern.


    Sprich: Ich kann von dem XP home Rechner auf die XP pro Rechner zugreifen, von den XP pro Rechnern jedoch nur wieder auf XP pro.


    Wo liegt der Fehler?


    LG, Ede


    PS: Rechte auf XP home wurden im abgesicherten Modus gesetzt.

  • Hallo.


    Da liegt das Problem. XP Home kann ohne explizite Rechte nicht auf XP Pro zugreifen. Du musst für die Benutzer auf XP Home ein Konto auf XP Pro errichten. Mit denselben Namen und Passwörter.
    Eventuell sollte der Benutzer "Jeder" mit "Leseberechtigungen" ausgestattet werden.


    Gruß Peter

    Birsctihe Frshocer hbaen haruesgfnuedn, dass es eagl ist, in whlecer Rhieenfgloe die Behsucbatn eenis Wtores sheten, slognae der etsre und ltetze Bhsucbate am rhitirgcn Pltaz sehten.

  • Anders rum Peter.
    XP Home kann problemlos auf XP Pro zugreifen, nur XP Pro nicht auf XP Home. Logisch, weil man in der XP Home die Rechte nicht vernünftig setzen kann.


    Tja *EdeWolf . So ist das eben mit der abgespeckten Version. Da fehlen relevante Teile. Bei der XP Home eben diese Rechntevergabe.
    Also besorg Dir noch ne XP Pro Version, spiel die da drauf und das Problem ist gelöst.

  • @Starfight: Da muss ich Dir widersprechen. Home hat die entsprechenden Teile, nur kann man normalerweise nicht darauf zugreifen. Starte Home mal im abgesicherten Modus, dann kannst Du Rechte ganz genauso vergeben wie in XP pro. Nur ist für mich noch nicht geklärt, warum ich - trotz entsprechender Rechtevergabe - von den pro-Rechnern keine Zugriffsberechtigung auf dem Home-Rechner kriege. Erkannt werden die Ordner/Dateien, nur Zugriff wird verwehrt.

  • Ich kann XP Home nicht im abgesicherten Modus starten, da ich kein XP Home habe.
    Und für mich ist es keineswegs unklar, warum es nicht funktioniert. XP Home interesiert sich nicht für die Rechtevergabe. Habe ich zwar schon geschrieben, aber glauben willst Du es offensichtlich nicht.


    Du könntest den Rechner natürlich ständig im abgesicherten Modus betreiben, dann geht es wahrscheinlich. :-)
    Nur, wer will das schon.

  • hallo,


    war es bei xp home(hab selber keines) bei den zugriffsrechten nicht so,das man bei der freigabe extra ein häckchen setzen musste um "den zugriff erlauben" zu erlauben? oder so änlich

    Acer Aspire Quad Q9300 2,5 GHz
    HDD 750 GB
    Ram 4 GB
    Vista Home Prem. SP2 64-bit

  • @Starfight: Wollte dich nicht ärgern :-)


    Aber: Wenn ich unter Home Rechte setzen kann (auch wenn es schwierig und verwinkelt ist, das überhaupt zu machen), dann ist es hinterher Sch***egal was Home darüber denkt: die Rechte sind erstmal gesetzt. Bei Pro kann man ja noch die lokalen Sicherheitseinstellungen entsprechend ändern... nur wie das in Home funktioniert, bzw, wie man da rankommt, da bin ich leider überfragt.


    Und was den Vorschlag von Dir betrifft, einfach ein Pro zu installieren: Ist nicht, weil gibts nicht, weil zu teuer. Ist nicht meine AUssage so, aber ich hab damit zu kämpfen.


    LG, Ede

  • Ist auf dem Home Rechner "Einfache Dateifreigabe" aktiviert?


    In die lok. Sicherheitseinstellungen solltest du per Start-Ausführen-gpedit.msc reinkommen, bin aber nicht ganz sicher, habe selber kein Home.


    Gruß
    Tobias

    Ihr aber, wenn es so weit sein wird
    Daß der Mensch dem Menschen ein Helfer ist
    Gedenkt unserer
    Mit Nachsicht.


    (Berthold Brecht - An die Nachgeborenen)

  • Zitat von *EdeWolf

    @Starfight: Wollte dich nicht ärgern :-)


    Hast Du mich geärgert ?
    Wann ? Wo ?


    Zitat

    Aber: Wenn ich unter Home Rechte setzen kann (auch wenn es schwierig und verwinkelt ist, das überhaupt zu machen), dann ist es hinterher Sch***egal was Home darüber denkt:


    Nein, keineswegs. Du kannst hundertmal über WInkelzüge und diverse Tricks rechte vergeben. Wenn XP-Home diese Funktionalität nicht unterstützt, dann geht es eben nicht.
    In einem anderen Fall war es z.B. so, das XP Home eine entsprechende Datei gar nicht hat. Da kannste dich auf den Kopf stellen, wenn CP net will, will es nicht.
    Sicher kann man die Rechte mit Winkelzügen trotzdem einstellen, das weis ich. Aber fragt XP Home diese dann auch ab ?


    Zitat

    Und was den Vorschlag von Dir betrifft, einfach ein Pro zu installieren: Ist nicht, weil gibts nicht, weil zu teuer. Ist nicht meine AUssage so, aber ich hab damit zu kämpfen.


    Tja, wie sagt man so schön. Man kann nur das Nutzen, was man hat.
    Wenn man eine Software mit Einschränkungen hat, muß man halt damit leben oder die andere Kaufen.
    Wenn ich ne Shareware einsetzte und nicht den Kaufpreis zahlen will, muß ich halt auch mit den einschränkungen leben.

  • Zitat von STS.metamensch


    In die lok. Sicherheitseinstellungen solltest du per Start-Ausführen-gpedit.msc reinkommen, bin aber nicht ganz sicher, habe selber kein Home.


    Nur zur Information, dass funktioniert nicht unter XP-Home, nicht mal im abgesicherten Modus.


    @Starfight,
    man kann im abgesicherten Modus auch unter XP-Home Rechte setzen, allerdings nicht so umfassend, wie im Pro.
    Die lokalen Sicherheitsstellungen sind allerdings mit keinem Winkelzug einzustellen. Da muss ich dir zustimmen, entweder damit leben und arbeiten oder ein bissel mehr bezahlen und volle Funktionalität erreichen.


    wiegehtsnur, die mit XP-Home arbeitet und nur manchmal darüber grummelt!

  • @wiegehtsnur
    Besten Dank für die Info. Dachte das lässt sich auch irgendwie drehen, hab aber bist jetzt nur 2-3 Home Systeme aufgesetzt, von daher halten sich meine Erfahrungen in Grenzen. Mein eigenes - war aufm Lap dabei - hat nichtmal den ersten Bootvorgang gesehen.... Vielleicht war das was voreilig :-)


    Wo Du schon damit arbeitest: IMHO müsste sich doch mit dieser Einfachen Dateifreigabe der Zugrif Pro -> Home reglen lassen, lieg ich da richtig?


    Bedankt nochmal,


    Gruß
    Tobias

    Ihr aber, wenn es so weit sein wird
    Daß der Mensch dem Menschen ein Helfer ist
    Gedenkt unserer
    Mit Nachsicht.


    (Berthold Brecht - An die Nachgeborenen)

  • Hallo STS.metamensch,
    Kann sein, dass ich dich nicht richtig verstehe, aber unter XP-Home gibt es die Möglichkeit der "einfachen Dateifreigabe" im Wortsinne nicht. Natürlich kann man Dateien freigeben (ich denke mal, das funzt wie die einfache Dateifreigabe unter Pro, ist aber nur so eine Vermutung und ich möchte nicht gehauen werden, wenn ich falsch liege! Eine höfliche Richtigstellung tut es auch!) und man kann auch von XP-Pro darauf zugreifen. Normaaaaaalerweise, aber leider ist das so eine Sache mit diesen Netzwerkzugriffen.
    Ich bin seit geraumer Zeit dabei, Problemlösungen zu sammeln und aufzulisten. Ist gar nicht so einfach und dauert einfach, es gibt so viele mit diesem Problem und die Lösungen, wenn sie denn verraten werden, sind manchmal schwer nachvollziehbar, klappen aber erstaunlicherweise.


    Gute Nacht sagt wiegehtsnur

  • Eigentlich fände ich es schade diesen Thread mit "Geht nicht" ausklingen zu lassen, denn es geht definitiv, nur manchmal nich auf Anhieb.
    Also alles auf Anfang.


    Öffne mal bitte auf jedem Rechner per Start-Ausführen-cmd-Enter eine kommnandozeile und gibt ein: ipconfig -all und sezt die Informationen hier
    rein. Desgleichen mit: net share.
    Verwendest Du, wenn Du versuchst von Pro auf Home zuzugreifen denselben Benutzer mit demselben Kennwort?
    Sind beide Computer in derselben Arbeitsgruppe?
    Hast Du schon versucht über die IP-Adresse auf die Home Möhre zuzugreifen oder nur per Computername und Netzwerkumgebung?
    Schon veruscht direkt ein Netzlaufwerk zu verbinden?
    Hast Du den Heimnetzwerkassistenten von Windows benutzt?


    Erstmal soviel, aber versprochen, da kommt noch was nach :-) Noch ist das Ende deines Netzwerks nicht in Sicht


    Gruß


    Tobias

    Ihr aber, wenn es so weit sein wird
    Daß der Mensch dem Menschen ein Helfer ist
    Gedenkt unserer
    Mit Nachsicht.


    (Berthold Brecht - An die Nachgeborenen)

  • Hi Leute, ich hab hier einfettes Problem mit meinem Netzwerk und komme einfach nicht weiter.
    Ich verfolge auch schon ne ganze Weile dieses Forum, aber nichts hilft.
    Wie schon in dem letzen Thema kann ich einfach nicht von meinem Laptop aus auf meinen PC zugreifen, andersrum funzts.
    Da hab ich dann mal den "restriktanonymous" Trick in der Regitstry ausprobiert und nach nem neustart gings. Allerdings hat sich dann auch der Wert 0 wieder auf 1 gesetzt und nach nem weiteren Neustart...aus die Maus.
    Da hab ich mir dann mal die tolle Netzwerkeinrichtungsbeschreibung aus dem selben Forum zu Herzen genommen und alles so gemacht wie es dort beschrieben wird.......nu krieg ich nicht mal mehr das eine mal, nach dem ändern der Registry und nem Neustart zugriff.
    Anpingen kann ich den Laptop, auch ein Spielchen macht die Verbindung mit (hab mal CS ausprobiert), ich seh aber auch nach tausend neuen Freigaben den anderen PC nicht.
    Beide PC's haben XP Pro mit SP1


    Hat irgendwer ne Idee?

  • Hallo Gast,
    scheinbar hast du ja schon alles versucht.
    Deshalb habe ich nur eine kurze Frage: Hast du zufällig XP-Antispy oder ein ähnliches Programm installiert?
    Und natürlich noch die obligatorische Zusatzfrage: Benutzt du eine Software-Firewall und hast du die schon mal probehalber deinstalliert?


    Ansonsten teile kurz mit, was du ausser dem in deinem Post genannten schon alles versucht hast. Das wird sonst sehr zäh, wenn wir hier erstmal alles aufzählen, was uns einfällt und du dann jedesmal antwortest: Das hab ich schon versucht.


    Viel Erfolg und Geduld (wirst du vielleicht brauchen) wünscht
    wiegehtsnur!

  • Guten Morgen carnivore,


    bitte erfülle den Wunsch von wiegehtsnur. Ich ahbe auch noch einen Osterwunsch.


    Bitte stell deine Frage in dem du einen neuen Beitrag, also ein neues Thema eröffnest.


    Wenn wir deine Anfrage hier anhängen und das Ursprungsdokument wird fortgesetzt, dann kommen wir alle mächtig durcheinander. Es wäre also auch in deinem Interesse einen eigenen Beitrag zu haben in dem nur auf dich und dein Problem eingegangen wird.


    Bis jetzt haben wir gemeinsam fast alles gelöst, lass uns da anknüpfen!

  • Danke @wiegehtsnur--
    Das mit der Firewall könnte auch EdeWolf helfen...
    @Ede
    Verwendest du eine Firewall? Wenn ja welche?
    Bei welchem Windows-Service Pack bist Du auf den Rechnern?
    Check mal, ob auf der Home die Windows Firewall aktiviert ist. Geh mal in die einstellungen der Windows Firewall (über Systemsteuerung) und guck mal ob unter dem Reiter Allgemein vielleicht Keine Ausnahmen zulassen an ist - dann weg damit. Im selben Dialog unter Reiter Ausnahmen bitte gucken ob der Haken für Datei und Druckfreigabe AN ist.


    Gruß
    Tobias

    Ihr aber, wenn es so weit sein wird
    Daß der Mensch dem Menschen ein Helfer ist
    Gedenkt unserer
    Mit Nachsicht.


    (Berthold Brecht - An die Nachgeborenen)

  • Vielen Dank für eure ersten Bemühungen.
    Die Ursache schien aber doch eine ganz andere zu sein.
    Nachdem ich mein Antivirenprogramm "AV Personal Edition" (den ich immer auf dem neuesten Stand hielt)gegen "avast! 4 Home" ersetzt hab, fand der Scanner doch gleich 7 Würmer und Trojaner und andere Malware, einen davon sogar im Arbeitsspeicher. Leider hab ich mir die bösen Jungs nicht alle gemerkt, um hier vielleicht anderen weiterhelfen zu können, fest steht aber das ich "AV Personal Edition" nicht wieder einsetzen werde.
    Nachdem also alle verunreinigunge gelöscht waren, hab ich noch mal versucht den "restictanonymous-Wert in der Registry auf 0 zu stellen und siehe da, ich kann wieder auf meinen Laptop zugreifen und selbst nach einem Neustart bleibt der Wert auf 0.
    Ich denke also, dass einer der Würmer verhindert hat, dass dieser Wert verändert wird. Ich vermute aber, dass der Wurm nicht verhindern wollte den Wert auf 0 zu stellen, sondern auf 2, da dieser Wert eine noch grössere Sicherheitsstufe erzwingt.
    Ich vermute dass einer der folgenden 3 Würmer/Trojaner der Übeltäter war. (hab die namen vergessen, weiss aber die schädlichen Dateien.
    1: Win32:Medac (Adw) c:\programm files\media\media acces\mediaacces.exe
    2: c:\Windows\System32\winlite.exe
    3: c:\Windows\System32\winpnp32.exe


    Zum Glück hat meine Firewall "Zone Alarm" die Programme daran gehindert mit der Aussenwelt Kontakt aufzunehemen und so schlimmeres verhindert.


    Ich hoffe vielleicht damit anderen geholfen zu haben, die das selbe Probelm haben.
    Bei mir scheint alles wieder in Orndung zu sein, deshalb mache ich auch kein neues Thema auf.
    Dank euch trotzdem für eure Bemühungen.