Automatisches Auslesen von Dateiinformationen deaktivieren

  • Hallo erstmal.
    Ich habe nun etwa 5 Stunden lang das Forum durchsucht und leider nichts zu meinem Problem gefunden. Daher erstelle ich hier jetzt mal einen neuen Thread zu dem Thema.


    Es geht darum: Der XP-Explorer hat die nervige Eigenschaft weitere Informationen aus Dateien herauszulesen. Etwa die ID3-Tags von Mp3-Dateien oder aber auch den Codex und die Auflösung bei Video-Files. Das mag ein ganz nettes Feature sein, mich aber nervt es einfach nur.
    Nicht nur das der Explorer bei jedem "neuem" Ordner den ich erstmalig öffne meint das mir Felder in der Detail-Ansicht fehlen (die er dann fröhlich einfügt, obwohl sie mich nur nerven). Nein, in dem moment wo ich den Focus auf ein File setze, läd er die Informationen erneut heraus um ein evtl gewolltes Abspielen schneller ermöglichen zu können. Dies hat leider einen blöden Effekt: Das File wird "benutzt". Wenn ich nun einen Ordner mit knapp 10Gigabyte an Dateien habe (sämtlich bei knapp 350mb groß), dauert es erstmal bis ich überhaupt etwas tun kann, da der Explorer erstmal 1x alle Files kurz anschaut (was er schon nicht soll). Wenn ich dann anfange und die Dateien umbenennen will, bekomme ich bei jedem 2-3 File die Fehlermeldung "Umbenennen nicht möglich, da die Datei sich im Zugriff befindet". Diese Fehlermeldung kommt definitiv durch das auslesen der Dateiinformationen beim setzen des Focus auf die Datei.
    Das nervt mich einfach gewaltig.
    Ich weiss das es möglich ist dieses Auslesen zu verhindern und zwar es global zu deaktivieren. Leider finde ich meine erste Quelle nicht wieder wo ich damals die Anleitung dafür her hatte.


    Ich habe mich stundenlang mit Google und allen möglichen Foren beschäftigt und habe nach mehreren Tagen leider noch immer keine Lösung gefunden.


    Ich hoffe das ihr mir weiterhelfen könnt, den das nervt wirklich gewaltig.


    Achja, auch wenn es sicher lieb gemeint ist, bitte spart mir Antworten wie "Nimm doch das Tool", "Benutz lieber", "Wenn du Linux...".
    Ich WILL den Explorer benutzen, ich WILL die Detail-Ansicht haben, ich WILL die Files per Hand umbenennen. Ich WILL nur kein automatisches Auslesen von weiteren Dateiinformationen.


    Vielen Dank für jede Hilfe.

  • Herzlich willkommen bei uns im Forum!


    Klare Ansage hast du gemacht...


    Der Eigenschaftsdialog des Explorer, hast du daran schon gebastelt? Also die Ordneroptionen einmal aufgerufen (Windowstaste + E - Extras - Ordneroptionen) und darin etwas verändert?


    Wenn man dazu in der Registry einen Wert ändern muss, dann warte mal auf den Admin ast, er kennt die Registry auswendig.


    Und wenn dich meine Antwort echt nervt, dann sorry....

  • Hi nochmals.


    Nein, die Antwort nervt natürlich nicht, den immerhin habe ich versäumt darauf hinzuweisen was ich bisher versucht habe.
    Ich habe meinen Explorer mit Hilfe der Ordneroptionen auf meine Anforderungen angepasst, was heisst: Herkömmliche Ansicht - Detailansicht - für alle Ordner übernehmen. Verstecke Dateien eingeblendet, die meisten weiteren Funktionen deaktiviert.
    Dies sollte eigentlich auch für alle Ordner gelten, leider nicht für solche die erst neu dazu kommen, oder in denen ich noch nie drin war... für diese denkt der Explorer sich: "Hey, der will mit sicherheit sofort sehen wer der Interpret ist und mit welcher Framerate der Song aufgenommen wurde sowie....."
    Tut mir leid, aber ich glaube fummeln an der Registry ist dafür sogar bitter nötig.

  • z.B.: Ich habe ein Zip-File mit Songs. -> Entpacken IN "Bla"
    Danach habe ich den Ordner Bla mit Songs drin, war vorher selber nie drin -> gehe rein -> Dateininformationen werden ausgelesen.


    Aber das ist ja auch nicht das Schlimme. Schlimmer ist eben das er die auch ausliest wenn die Datei markiert wird und damit ein schnelles umbenennen per Hand teils blockiert.
    Daher muss das weg.

  • also, ich könnte mir vorstellen, das es am arbeitsspeicher(wenn es zu wenig ist), oder an einer zu großen/kleinen einstellung für die Auslagerungsdatei liegt. llt mal ein paar angaben?

    Acer Aspire Quad Q9300 2,5 GHz
    HDD 750 GB
    Ram 4 GB
    Vista Home Prem. SP2 64-bit

  • Ich habe 1,5 Gig Ram und 3gig auslagerungsdatei. Daran kann es eigentlich nicht liegen und selbst wenn, wäre das nur ein "umgehen" des problems und nicht eine Beseitigung der Ursache. Umgehen kann ich das Problem auch in dem ich vor dem Umbenennen kurz 1 Sekunde warte, dann hat er die Informationen ausgelesen und die Datei ist nicht mehr im Zugriff.


    Ich WILL aber nicht warten müssen weil XP meint zu wissen was ich will und daher die Infos ausliest. Ich will XP verbieten die Infos auszulesen.


    Daher: Ich will eine Möglichkeit finden das Auslesen zu unterbinden und nicht eine Möglichkeit finden damit zu leben. :) Aber danke für die Hilfe

  • da wirst du aber schlechte karten haben. schon alleine die zuweisung der datei zu einem programm dauert fast eine sekunde.

    Acer Aspire Quad Q9300 2,5 GHz
    HDD 750 GB
    Ram 4 GB
    Vista Home Prem. SP2 64-bit

  • Liegt es nicht.
    Ich habe knapp 1.3 Gig Arbeitsspeicher (400er)


    Ich hatte das Problem vor einiger Zeit schonmal und hatte zu der Zeit weniger Arbeitsspeicher. Damals fand ich eine möglichkeit dieses Auslesen generell zu deaktivieren (ich glaube die Lösung ging mit dem Problem mit dem MP3-Tags einher. Diese waren damals in der lage nen Buffer-Overflow zu verursachen).
    Jedenfalls war es möglich das auslesen generell zu verhindern.
    Und genau das würde ich gerne tun.
    Ich will halt eben nicht meinen PC soweit aufrüsten das er mit dem Problem schneller fertigwird als es auftritt, sondern das Problem beseitigen.


    Vielen Dank nochmals

  • Zitat von Helloween

    da wirst du aber schlechte karten haben. schon alleine die zuweisung der datei zu einem programm dauert fast eine sekunde.


    Wie gesagt, genau das will ich ja auch deaktivieren. Ich weiss das es geht, den das Problem hatte ich schonmal und ich habe es damals behoben bekommen.
    Das Programm das sich "zuweist" kann sich nach meinem Erachten auch noch zuweisen wenn ich wirklich einen Doppelklick auf die Datei mache. Das muss nicht erfolgen wenn ich den Focus auf das File setze.


    Aber offenbar kann mir hier nicht geholfen werden (Auch wenn ich eindeutig einsehe das man bemüht ist :) )
    Ich hoffe ich finde die Lösung von damals wieder und lasse euch dann auch gerne teilhaben.


    Vielen Dank.
    (oder kommt der mit den Ahnung von der Registry nochmal vorbei?)

  • aber "ast" ist bestimmt heute noch mal online
    und wird sicher auf dein prob aufmerksam.
    schau ein fach öfter mal vorbei, vielleicht
    hat er dann schon ne antwort parat.

    das leben ist sch****e aber die grafik ist geil!
    rechtschreibfehler sind absichtlich eingebaut worden, damit sich der leser nicht so langweilt

    "Der erste Trunk aus dem Becher der Naturwissenschaft macht atheistisch;
    aber auf dem Grund des Bechers wartet Gott."
    Werner Heisenberg, Atomphysiker


    bye soucerer72™®©

  • Klingt stark nach Indexdienst, kannst du unter Verwaltung -> Dienste deaktivieren. Vielleicht löst dass das Problem...


    An die dumme Stirne gehört als Argument von Rechts wegen die geballte Faust. (Nietsche)

  • wenn das so ist. explorer - extras - ordneroptionen - dateityp. alle einträge löschen. und das gleiche kann man auch in der regedit (weiss im moment bloss nicht wo).

    Acer Aspire Quad Q9300 2,5 GHz
    HDD 750 GB
    Ram 4 GB
    Vista Home Prem. SP2 64-bit