Bootvorgang mit Bootvis -> Hilfe bei analyse

  • Hi Leutz,


    bin neu hier und hab auch gleich mal nen Problemchen.


    Also es geht um folgendes:
    Ich hab mir zu Weihanchten einen Samsung P35 1,6GHz Laptop geleistet. Habe dort nun WinXP Prof. installiert und soweit alles andere was ich benötige auch. Dann hab ich den Bootvorgang mit Bootvis analysiert und optimiert. Ergab eine verbesserung von ca. 5sec.
    So alles schön und gut, aber trotzdem dauert mein Bootvorgang noch schlappe 83 sec und das ist mir echt zu langsam für nen 1,6 Centrino.
    So, ich nochmal das komplette System neu Installiert und Bootvis rüber und es ergab, dass selbst bei dem frischen System der Bootvorgang solang dauert (ca. 75 sec).
    Dann hab ich mir das ganze mal genauer angeschaut und habe festgestellt, dass beim Booten das System an einer Stelle wirklich ca. 20 sec lang nix macht und einfach steht. Laut Bootvis werden keine Driver oder Prozesse in der Zeit gestartet und die CPU ist auch nur minimale Auslastung.
    Was passiert da nur? Wie kann man das beheben?


    Würde mich echt freuen, wenn ihr mir da weiterhelfen könntet.
    Ansonsten: XP-Antspy -> ausgeführt
    einige Regestryänderungen hier ausm Forum ebenfalls ausgeführt, aber System wird nicht schneller.


    mfg Digga

  • Hallo Digga,


    wo ist dein Problem?


    Ein Toshiba (1800, Centrino) , vergleichbar mit deinem Schläpptopp, aus dem Markt mit ohne Mehrwertsteuer für einen Tag, benötigt trotz 1599 Eurolein Anschaffungspreis 2 Minuten!


    Das liegt aber nicht am Centrino!


    Liste doch mal auf, was denn alles installiert ist und schon serienmäßig vorgegeben war. Hier liegt das Problem! Ist auf dem Samsung auch schon ein Virenscanner, Norton und so Zeug drauf? Dann kommt noch deine eigene Software und schwupps sind wir eben über einer Minute.


    Also liste mal auf, was denn so alles beim Booten mit hoch muss...

  • Hallo Digga!


    Hier ein paar Tipps.
    Bei Bootvis muss der Dienst für den Taskplaner aktiv bleiben damit das Prefetch der Daten erhalten bleibt.
    Zum anderen würde ich Automatisch nach Netzwerkordnern und Drucker suchen,deaktivieren.
    Ist dein Schleppi mit einer W.Lan karte ausgestattet und du nutzt sie nicht. deaktiviere sie.
    XP-Antispy sollte erst zum Einsatz kommen wenn alle M$ Produkte auf deinem Rechner richtig laufen und Produkt registriert ist.( meine Erfahrung )
    Ich Persönlich halte nicht viel von Bootvis, weil alle Einstellungen auch über die Registry zu tätigen sind und das stellt kein Ballast da wie das Bootvis Tool.


    Gruß
    Amtsrat

  • @kaiserfive
    Die Auflistung mach ich noch, aber soviel schon mal vor weg, ich hab das auch mal auf nem nackten System probiert und da dauert es ähnlich lange! Ich werd dazu auch mal den Trace von Bootvis mit posten...


    Amtsrat
    1.Taskplaner aktiv
    2.Netzordner u.... is deaktiviert
    3.Habe erst alles installed und dann Antispy ausgeführt


    Naja nen bissle was bringt bootvis schon,aber für mich sind diese lücken unerklärlich, wo er meiner Meinung nach nix macht...


    mfg

  • @hendryk
    Hi,
    habe fast immer ne feste IP


    @all
    Hi,
    ichposte jetzt mal nen screenshot vom bootvis ergebnis. Vielleicht versteht ihr ja dann besser was ich meine. Mich ärgert der Schluss, wo der Rechner anscheinend nix tut oder täuscht das? Aber selbst die CPU hat fast 0 Auslastung. Was macht mein Rechner in der Zeit? Er steht doch einfach nur Still oder? Wie kann ich das ändern?
    Hier der Screener:

  • Schlepper haben eh die Tendenz etwas langsamer zu starten als Desktops und seit SP2 ist die erzwungene ruhige Gangart auch ein Prob, jaja. Centrinos hmmm... Stromsparen vor Leistung. Beides zusammen sieht nicht so gut aus, wobei ich bis 120 sek. beim Schleppi noch für recht gut halte und diesen Wert unterschreitest Du ja deutlich.


    Häng Dich jetzt nicht an BOOTVIS auf, die Funktionen sind bei XP nicht mehr so wichtig, denn XP arbeitet mit "Prefetching" und die Bootvis-Optimize-Funktionen kannst Du auch manuell unter XP aufrufen. Deshalb stellt MS das ja auch nicht mehr zum DL bereit.


    Was hast Du denn nun alles zur Optimierung der Startdateien gemacht?
    =======================
    Wichtiger sind die Sleep-Time-Activities (Wartungsaufgaben) zu optimieren, was nicht nur dem System-, sondern auch den Programmstarts zugute kommt.


    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction


    Wert REG_SZ "Enable" steht auf "Y"?


    Dadurch wird eigentlich bei/nach 10 menütigem Leerlauf das Defrag der Startdateien gestartet, wenn Du Pech hast aber auch mitten beim Spielen oder sonstwas.


    Besser den Wert auf "N" setzen und das Ganze ab und an manuell starten.


    Win- + R-Taste und Eingabe für LW C:\


    defrag c: -b <- das ist es, was auch Bootvis macht.


    Je mehr die Dateien fragmentiert abgelegt sind, je länger dauert das Defraggen, es erscheint eine DOS-Box ohne Inhaltsanzeige, die Festplatte rattert und schließt sie sich beim Beenden wieder selbstständig..
    Mach das 1-2 mal die Woche manuell, dann dauert das ca. 1-3 sek.


    Auch über "Ausführen"


    rundll32.exe advapi32.dll,ProcessIdleTasks


    ...dann ist das ebenfalls erledigt (da rattert sie ebenfalls, allerdings ohne irgendeine Anzeige).
    Manch Einer hat sich sicher schon mal gewundert, wieso die Platte rödelt obwohl man nichts gemacht hat. Das sind dann die Wartungen im Hintergrund.


    Den Prefetch-Ordner auch 1mal die Woche löschen, da sich da auch ne Menge gespeicherter Müll von irgendwann mal gestarteten Programmen ansammelt die seltenst gebraucht werden.


    Dann den oft/gern benutzten Progs in den Verknüpfungen (z.B. QuickLaunch) ein /prefetch:1 anhängen...


    Beispiel: "C:\Programme\Mozilla Firefox\firefox.exe" /prefetch:1


    ...um Diese vorrangig im Prefetch-Ordner abzulegen.


    Die Temp-Ordner ebenfalls löschen, am besten beim Start per Batch.


    echo off
    rd /s /q "%userprofile%\lokale einstellungen\Temp"
    md "%userprofile%\lokale einstellungen\Temp"
    rd /s /q %systemroot%\Temp
    md %systemroot%\Temp


    %systemroot% ist dabei nicht zwingend %windir% reicht auch.


    Diese Batch machts aber auch per D-Klick, falls Du es manuell machen und den Prefetch-Ordner auch gleich mit leeren willst, dann...


    del /f /q *.* %windir%\prefetch


    ...anhängen, oder separat auch in einer Batch.


    Die Autostartbereiche ausmisten.


    Wenn nichts von T-Online und/oder Norton installiert ist, sowie keine alten 16 Bit-Progs laufen sollen, kannst Du das Abarbeiten der System.ini und Win.ini komplett deaktivieren.


    "Ausführen" -> msconfig

    Allgemein -> "Benutzerdefinierten Systemstart" markieren und dann die beiden Haken bei "Win.ini und System.ini verarbeiten" rausnehmen.


    Systemstart -> alles raus was Du nicht unbedingt sofort am Laufen haben willst.


    Dienste -> Haken bei "Alle MS-Dienste ausblenden" setzen und schauen was da von angelegten Diensten installierter Programme nicht unbedingt starten muss.


    Wenn fertig OK und auf "Nicht neustarten".


    Dann das ganze LW c: defragmentieren.


    "Ausführen" ->cmd und dann in der DOS-Box...
    defrag c:


    ...oder die GUI starten per dfrg.msc über "Ausführen".


    Wichtig ist IMO vor allem, das die "Speicherplatzfragmentierung" auf =0% steht.


    Zum Schluss dann einen Neustart und direkt ein weiteres Bootvis-Trace (Altes vorher umbenennen, sonst ist Das weg) erstellen und vergleichst die Beiden mal miteinander.


    Mal sehn was dann bei Deinem schlappen Schleppi :mrgreen: rüberkommt.

    hope dies last


    tschöö... ast

  • Hi, danke für eure Hilfe!


    ast
    Danke, ich werd dann jetzt die Tage deine Tipps nachund nach alle ausprobieren und halte euch natürlich auf dem laufenen! ;-)


    Aber mal ne ganz andere Frage, woher weißt du sowas alles? Ich will sowas auch alles wissen ;-)



    mfg

  • Hi,


    so ich hab mal etwas getestet,obwohl ich mit den Angaben von "ast" nicht ganz klar kam.
    Hab noch das eine oder andere Mal mit Bootvis experimentiert, dabei ist mir folgendes aufgefallen:
    Also wenn ich Bootvis starte und dann auf Trace -> Optimize System klicke und dann reboote, läuft der Balken beim Systemstart höchstens 3mal durch (so muss es sein). Tu ich aber danach mein Rechner ganz normal booten läuft der Balken wieder 9-10 mal durch.
    Wie kommt das? Kann das jemand von euch vielleicht erklären? Also ich finds echt merkwürdig....


    Aso, und irgendwie braucht mein Norton Antivirus laut Bootvis nur noch 0,15sec zum starten. Kewl wa....


    mfg Digga

  • Kann mir das denn keiner Erklären?
    Bei Optimize System werden doch auch beim neuen boot alle Driver und Prozesse geladen, aber warum läuft denn da nur der Balken 3mal durch und beim normalen booten ca. 10 mal?


    FAZIT:
    Es müsste auch immer so schnell gehen!

  • Hallo ast,


    absolut Klasse deine Tips, vielen Dank!
    Habe schon länger probiert wie man diesen Blödsinn ausschalten kann.


    Nochmal vielen Dank und schreib weiter so tolle Tips!


    Tschüß sihola

  • Digga: Erklärung Laufbalken 3x vs. 10x: Weil bootvis beim Trace die Option /noguiboot verwendet (AFAIK). Kannst Du auch manuell über deine Boot-Ini einstellen, bringt auch einen minimalen Geschw.-Zuwachs beim Boot. Der Bootvorgang dauer doch nciht unterschiedlich lang, oder (Laufbalken hin oder her).


    Gruß


    Tobias

    Ihr aber, wenn es so weit sein wird
    Daß der Mensch dem Menschen ein Helfer ist
    Gedenkt unserer
    Mit Nachsicht.


    (Berthold Brecht - An die Nachgeborenen)